# CVE-2018-14523: Aubio is vulnerable to out of bound read when samplerate > 50kHz

> A buffer over-read in the aubio library allows attackers to cause a denial of service via crafted audio input.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Jul 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-14523, GHSA-3x58-8qmv-wqw5, PYSEC-2018-63, UBUNTU-CVE-2018-14523

## What is CVE-2018-14523?

CVE-2018-14523 is a high-severity memory corruption vulnerability in Opensuse Leap, published on 23 Jul 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An issue was discovered in aubio 0.4.6. A buffer over-read can occur in new_aubio_pitchyinfft in pitch/pitchyinfft.c, as demonstrated by aubionotes.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2018-14523?

3 open source packages ship an affected version, including aubio. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `aubio` | PyPI | All versions | 0.4.7 |
| `aubio` | PyPI | All versions | 0.4.7 |
| `aubio` | PyPI | All versions | 0.4.7 |

Products: Aubio Aubio, Opensuse Leap, Suse Linux Enterprise.

## How do I fix CVE-2018-14523?

Upgrade aubio to 0.4.7 or later.

## Is CVE-2018-14523 being exploited?

There is no known exploitation of CVE-2018-14523 in the wild and no public exploit code.

## Other vulnerabilities in Opensuse Leap

- [CVE-2018-19800](https://insights.sbomify.com/CVE-2018-19800/): aubio Buffer Overflow vulnerability (critical 9.8)
- [CVE-2018-14521](https://insights.sbomify.com/CVE-2018-14521/): Aubio is vulnerable to denial of service via aubio_source_avcodec_readframe function (high 8.8)
- [CVE-2018-14522](https://insights.sbomify.com/CVE-2018-14522/): Aubio is vulnerable to denial of service via aubio_pitch_set_unit function (high 8.8)
- [CVE-2018-19801](https://insights.sbomify.com/CVE-2018-19801/): Aubio is vulnerable to a NULL pointer dereference in new_aubio_filterbank (high 7.5)
- [CVE-2018-19802](https://insights.sbomify.com/CVE-2018-19802/): Aubio is vulnerable to a NULL pointer dereference in new_aubio_notes function (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-14523 and fix it if it is affected.

What it is: CVE-2018-14523 is a high-severity memory corruption vulnerability in Opensuse Leap, published on 23 Jul 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-14523 in the wild and no public exploit code.

Affected packages and fixed versions:
- aubio (PyPI): affected all versions; fixed in 0.4.7
- aubio (PyPI): affected all versions; fixed in 0.4.7
- aubio (PyPI): affected all versions; fixed in 0.4.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-14523/ (Markdown: https://insights.sbomify.com/CVE-2018-14523/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-14523
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-14523
- OSV: https://osv.dev/vulnerability/CVE-2018-14523

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-14523/
Summaries are generated and may contain mistakes; the official description above is the record.
