CVE-2018-14630 Moodle XML import of ddwtos could lead to intentional remote code execution
Attackers can execute arbitrary PHP code by importing malicious drag-and-drop quiz questions, allowing full remote code execution on the server.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2018-14630?
CVE-2018-14630 is a high-severity code injection vulnerability in Moodle Moodle, published on 17 Sep 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
moodle before versions 3.5.2, 3.4.5, 3.3.8, 3.1.14 is vulnerable to an XML import of ddwtos could lead to intentional remote code execution. When importing legacy 'drag and drop into text' (ddwtos) type quiz questions, it was possible to inject and execute PHP code from within the imported questions, either intentionally or by importing questions from an untrusted source.
Which versions are affected by CVE-2018-14630?
8 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 3.1.14 |
moodle/moodle Packagist | All versions | 3.1.14 |
moodle/moodle Packagist | From 3.2.0 | 3.3.8 |
moodle/moodle Packagist | From 3.2.0 | 3.3.8 |
moodle/moodle Packagist | From 3.4.0 | 3.4.5 |
moodle/moodle Packagist | From 3.4.0 | 3.4.5 |
2 more packages
moodle/moodle Packagist | From 3.5.0 | 3.5.2 |
moodle/moodle Packagist | From 3.5.0 | 3.5.2 |
Products include Moodle Moodle.
How do I fix CVE-2018-14630?
Upgrade moodle/moodle to a fixed version for your release line: 3.1.14, 3.3.8, 3.4.5 or 3.5.2.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2018-14630 being exploited?
There is no known exploitation of CVE-2018-14630 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-c3pr-h96w-2jjg, UBUNTU-CVE-2018-14630.