{"answers":{"affected":"8 open source packages ship an affected version, including moodle/moodle. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-14630 in the wild and no public exploit code.","fix":"Upgrade moodle/moodle to a fixed version for your release line: 3.1.14, 3.3.8, 3.4.5 or 3.5.2.","what":"CVE-2018-14630 is a high-severity code injection vulnerability in Moodle Moodle, published on 17 Sep 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-14630 and fix it if it is affected.\n\nWhat it is: CVE-2018-14630 is a high-severity code injection vulnerability in Moodle Moodle, published on 17 Sep 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-14630 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- moodle/moodle (Packagist): affected all versions; fixed in 3.1.14\n- moodle/moodle (Packagist): affected all versions; fixed in 3.1.14\n- moodle/moodle (Packagist): affected from 3.2.0; fixed in 3.3.8\n- moodle/moodle (Packagist): affected from 3.2.0; fixed in 3.3.8\n- moodle/moodle (Packagist): affected from 3.4.0; fixed in 3.4.5\n- moodle/moodle (Packagist): affected from 3.4.0; fixed in 3.4.5\n- moodle/moodle (Packagist): affected from 3.5.0; fixed in 3.5.2\n- moodle/moodle (Packagist): affected from 3.5.0; fixed in 3.5.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-14630/ (Markdown: https://insights.sbomify.com/CVE-2018-14630/index.md)","id":"CVE-2018-14630","markdown":"https://insights.sbomify.com/CVE-2018-14630/index.md","name":"CVE-2018-14630","record":{"aliases":["GHSA-c3pr-h96w-2jjg","UBUNTU-CVE-2018-14630"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Moodle LMS","requires_auth":"none","summary":"Attackers can execute arbitrary PHP code by importing malicious drag-and-drop quiz questions, allowing full remote code execution on the server.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"moodle","vendor":"moodle"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"moodle before versions 3.5.2, 3.4.5, 3.3.8, 3.1.14 is vulnerable to an XML import of ddwtos could lead to intentional remote code execution. When importing legacy 'drag and drop into text' (ddwtos) type quiz questions, it was possible to inject and execute PHP code from within the imported questions, either intentionally or by importing questions from an untrusted source.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Moodle XML import of ddwtos could lead to intentional remote code execution","id":"CVE-2018-14630","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"moodle:moodle","products":["moodle:moodle"],"type":"code_injection","year":"2018"},"n_packages":8,"n_references":6,"next":{"headline":"Moodle Cross-site Scripting","id":"CVE-2018-14631"},"packages":[{"ecosystem":"Packagist","fixed":["3.1.14"],"introduced":["0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-c3pr-h96w-2jjg"},{"ecosystem":"Packagist","fixed":["3.1.14"],"introduced":["0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-c3pr-h96w-2jjg"},{"ecosystem":"Packagist","fixed":["3.3.8"],"introduced":["3.2.0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-c3pr-h96w-2jjg"},{"ecosystem":"Packagist","fixed":["3.3.8"],"introduced":["3.2.0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-c3pr-h96w-2jjg"},{"ecosystem":"Packagist","fixed":["3.4.5"],"introduced":["3.4.0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-c3pr-h96w-2jjg"},{"ecosystem":"Packagist","fixed":["3.4.5"],"introduced":["3.4.0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-c3pr-h96w-2jjg"},{"ecosystem":"Packagist","fixed":["3.5.2"],"introduced":["3.5.0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-c3pr-h96w-2jjg"},{"ecosystem":"Packagist","fixed":["3.5.2"],"introduced":["3.5.0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-c3pr-h96w-2jjg"}],"prev":{"headline":"Denial of service in samba","id":"CVE-2018-14629"},"products":["moodle"],"published":"2018-09-17","related":[{"cvss_score":10,"headline":"File upload in n/a","id":"CVE-2006-4935","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Moodle does not properly validate module instance id","id":"CVE-2006-4936","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Unknown \"front page vulnerability with Moodle servers\" for Moodle before 1.3.2 has unknown impact and attack vectors.","id":"CVE-2004-2233","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Cross-site scripting in n/a","id":"CVE-2004-2235","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2004-2236","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Unknown vulnerability in Moodle before 1.3.4 has unknown impact and attack vectors, related to \"strings in Moodle texts.\"","id":"CVE-2004-2237","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Multiple unknown vulnerabilities in Moodle before 1.5.1 have unknown impact and attack vectors.","id":"CVE-2005-2247","kev_date_added":null,"published":"2005-07-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["[UNKNOWN]"]},"summary":"Attackers can execute arbitrary PHP code by importing malicious drag-and-drop quiz questions, allowing full remote code execution on the server.","url":"https://insights.sbomify.com/CVE-2018-14630/"}