# CVE-2018-14630: Moodle XML import of ddwtos could lead to intentional remote code execution

> Attackers can execute arbitrary PHP code by importing malicious drag-and-drop quiz questions, allowing full remote code execution on the server.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Sep 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-c3pr-h96w-2jjg, UBUNTU-CVE-2018-14630

## What is CVE-2018-14630?

CVE-2018-14630 is a high-severity code injection vulnerability in Moodle Moodle, published on 17 Sep 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

moodle before versions 3.5.2, 3.4.5, 3.3.8, 3.1.14 is vulnerable to an XML import of ddwtos could lead to intentional remote code execution. When importing legacy 'drag and drop into text' (ddwtos) type quiz questions, it was possible to inject and execute PHP code from within the imported questions, either intentionally or by importing questions from an untrusted source.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2018-14630?

8 open source packages ship an affected version, including moodle/moodle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle/moodle` | Packagist | All versions | 3.1.14 |
| `moodle/moodle` | Packagist | All versions | 3.1.14 |
| `moodle/moodle` | Packagist | From 3.2.0 | 3.3.8 |
| `moodle/moodle` | Packagist | From 3.2.0 | 3.3.8 |
| `moodle/moodle` | Packagist | From 3.4.0 | 3.4.5 |
| `moodle/moodle` | Packagist | From 3.4.0 | 3.4.5 |
| `moodle/moodle` | Packagist | From 3.5.0 | 3.5.2 |
| `moodle/moodle` | Packagist | From 3.5.0 | 3.5.2 |

Products: Moodle Moodle.

## How do I fix CVE-2018-14630?

Upgrade moodle/moodle to a fixed version for your release line: 3.1.14, 3.3.8, 3.4.5 or 3.5.2.

## Is CVE-2018-14630 being exploited?

There is no known exploitation of CVE-2018-14630 in the wild and no public exploit code.

## Other vulnerabilities in Moodle Moodle

- [CVE-2006-4935](https://insights.sbomify.com/CVE-2006-4935/): File upload in n/a (critical 10.0)
- [CVE-2006-4936](https://insights.sbomify.com/CVE-2006-4936/): Moodle does not properly validate module instance id (critical 10.0)
- [CVE-2004-2233](https://insights.sbomify.com/CVE-2004-2233/): Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors. (critical 10.0)
- [CVE-2004-2235](https://insights.sbomify.com/CVE-2004-2235/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2004-2236](https://insights.sbomify.com/CVE-2004-2236/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-14630 and fix it if it is affected.

What it is: CVE-2018-14630 is a high-severity code injection vulnerability in Moodle Moodle, published on 17 Sep 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-14630 in the wild and no public exploit code.

Affected packages and fixed versions:
- moodle/moodle (Packagist): affected all versions; fixed in 3.1.14
- moodle/moodle (Packagist): affected all versions; fixed in 3.1.14
- moodle/moodle (Packagist): affected from 3.2.0; fixed in 3.3.8
- moodle/moodle (Packagist): affected from 3.2.0; fixed in 3.3.8
- moodle/moodle (Packagist): affected from 3.4.0; fixed in 3.4.5
- moodle/moodle (Packagist): affected from 3.4.0; fixed in 3.4.5
- moodle/moodle (Packagist): affected from 3.5.0; fixed in 3.5.2
- moodle/moodle (Packagist): affected from 3.5.0; fixed in 3.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-14630/ (Markdown: https://insights.sbomify.com/CVE-2018-14630/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-14630
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-14630
- OSV: https://osv.dev/vulnerability/CVE-2018-14630

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-14630/
Summaries are generated and may contain mistakes; the official description above is the record.
