CVE-2018-14631 Moodle Cross-site Scripting
Reflected XSS in Moodle Boost theme blog search allows attackers to execute scripts via malicious links, potentially leading to session hijacking.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2018-14631?
CVE-2018-14631 is a high-severity cross-site scripting vulnerability in Moodle Moodle, published on 17 Sep 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
moodle before versions 3.5.2, 3.4.5, 3.3.8 is vulnerable to a boost theme - blog search GET parameter insufficiently filtered. The breadcrumb navigation provided by Boost theme when displaying search results of a blog were insufficiently filtered, which could result in reflected XSS if a user followed a malicious link containing JavaScript in the search parameter.
Which versions are affected by CVE-2018-14631?
6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.3 | 3.3.8 |
moodle/moodle Packagist | From 3.3 | 3.3.8 |
moodle/moodle Packagist | From 3.4 | 3.4.5 |
moodle/moodle Packagist | From 3.4 | 3.4.5 |
moodle/moodle Packagist | From 3.5 | 3.5.2 |
moodle/moodle Packagist | From 3.5 | 3.5.2 |
Products include Moodle Moodle.
How do I fix CVE-2018-14631?
Upgrade moodle/moodle to a fixed version for your release line: 3.3.8, 3.4.5 or 3.5.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2018-14631 being exploited?
There is no known exploitation of CVE-2018-14631 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-gqrp-qhv8-phrv, UBUNTU-CVE-2018-14631.