# CVE-2018-14636: Openstack Neutron vulnerable to eavesdropping on private traffic

> Attackers can inspect traffic from other instances on the same hypervisor during live migration if port states are manipulated, exposing sensitive network data.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Sep 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-14636, GHSA-8q95-jj7p-x93x, PYSEC-2018-94, UBUNTU-CVE-2018-14636

## What is CVE-2018-14636?

CVE-2018-14636 is a medium-severity vulnerability in The Openstack Project openstack-neutron, published on 10 Sep 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Live-migrated instances are briefly able to inspect traffic for other instances on the same hypervisor. This brief window could be extended indefinitely if the instance's port is set administratively down prior to live-migration and kept down after the migration is complete. This is possible due to the Open vSwitch integration bridge being connected to the instance during migration. When connected to the integration bridge, all traffic for instances using the same Open vSwitch instance would potentially be visible to the migrated guest, as the required Open vSwitch VLAN filters are only applied post-migration. Versions of openstack-neutron before 13.0.0.0b2, 12.0.3, 11.0.5 are vulnerable.

Weakness: CWE-300 (Channel Accessible by Non-Endpoint)

## Which versions are affected by CVE-2018-14636?

7 open source packages ship an affected version, including neutron. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `neutron` | PyPI | From 11.0.0 | 11.0.5 |
| `neutron` | PyPI | From 11.0.0 | 11.0.5 |
| `neutron` | PyPI | From 12.0.0 | 12.0.3 |
| `neutron` | PyPI | From 12.0.0 | 12.0.3 |
| `neutron` | PyPI | From 13.0.0.0b1 | 13.0.0.0b2 |
| `neutron` | PyPI | From 13.0.0.0b1 | 13.0.0.0b2 |
| `neutron` | PyPI | From 7.0.0 | 11.0.5, 12.0.3 |

Products: Openstack Neutron.

## How do I fix CVE-2018-14636?

Upgrade neutron to a fixed version for your release line: 11.0.5, 12.0.3 or 13.0.0.0b2.

## Is CVE-2018-14636 being exploited?

There is no known exploitation of CVE-2018-14636 in the wild and no public exploit code.

## Other vulnerabilities in The Openstack Project openstack-neutron

- [CVE-2021-38598](https://insights.sbomify.com/CVE-2021-38598/): OpenStack Neutron vulnerable to hardware address impersonation (critical 9.1)
- [CVE-2015-8914](https://insights.sbomify.com/CVE-2015-8914/): OpenStack Neutron allows remote attackers to bypass an intended ICMPv6-spoofing protection mechanism (critical 9.1)
- [CVE-2016-5362](https://insights.sbomify.com/CVE-2016-5362/): OpenStack Neutron allows remote attackers to bypass an intended DHCP-spoofing protection mechanism (high 8.2)
- [CVE-2016-5363](https://insights.sbomify.com/CVE-2016-5363/): OpenStack Neutron Intended MAC-spoofing protection mechanism bypass (high 8.2)
- [CVE-2014-3632](https://insights.sbomify.com/CVE-2014-3632/): Privilege escalation in n/a (high 7.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-14636 and fix it if it is affected.

What it is: CVE-2018-14636 is a medium-severity vulnerability in The Openstack Project openstack-neutron, published on 10 Sep 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-14636 in the wild and no public exploit code.

Affected packages and fixed versions:
- neutron (PyPI): affected from 11.0.0; fixed in 11.0.5
- neutron (PyPI): affected from 11.0.0; fixed in 11.0.5
- neutron (PyPI): affected from 12.0.0; fixed in 12.0.3
- neutron (PyPI): affected from 12.0.0; fixed in 12.0.3
- neutron (PyPI): affected from 13.0.0.0b1; fixed in 13.0.0.0b2
- neutron (PyPI): affected from 13.0.0.0b1; fixed in 13.0.0.0b2
- neutron (PyPI): affected from 7.0.0; fixed in 11.0.5, 12.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-14636/ (Markdown: https://insights.sbomify.com/CVE-2018-14636/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-14636
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-14636
- OSV: https://osv.dev/vulnerability/CVE-2018-14636

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-14636/
Summaries are generated and may contain mistakes; the official description above is the record.
