CVE-2018-14718 Arbitrary Code Execution in jackson-databind

Critical 9.8 Published Updated

Remote attackers can execute arbitrary code via unsafe polymorphic deserialization in the jackson-databind library.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2018-14718?

CVE-2018-14718 is a critical unsafe deserialization vulnerability in Debian Debian Linux, published on 2 Jan 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

FasterXML jackson-databind 2.x before 2.9.7 might allow remote attackers to execute arbitrary code by leveraging failure to block the slf4j-ext class from polymorphic deserialization.

Weakness: CWE-502

Which versions are affected by CVE-2018-14718?

8 open source packages ship an affected version, including com.fasterxml.jackson.core:jackson-databind. It affects 25 products.

PackageAffectedFixed in
com.fasterxml.jackson.core:jackson-databind MavenFrom 2.0.02.6.7.3
com.fasterxml.jackson.core:jackson-databind MavenFrom 2.0.02.6.7.3
com.fasterxml.jackson.core:jackson-databind MavenFrom 2.7.02.7.9.5
com.fasterxml.jackson.core:jackson-databind MavenFrom 2.7.02.7.9.5
com.fasterxml.jackson.core:jackson-databind MavenFrom 2.8.02.8.11.3
com.fasterxml.jackson.core:jackson-databind MavenFrom 2.8.02.8.11.3
2 more packages
com.fasterxml.jackson.core:jackson-databind MavenFrom 2.9.02.9.7
com.fasterxml.jackson.core:jackson-databind MavenFrom 2.9.02.9.7

Products include Debian Debian Linux, Fasterxml Jackson-Databind, Netapp Oncommand Workflow Automation, Netapp Snapcenter, Netapp Steelstore Cloud Integrated Storage, Oracle Banking Platform and 19 more.

How do I fix CVE-2018-14718?

Upgrade com.fasterxml.jackson.core:jackson-databind to a fixed version for your release line: 2.6.7.3, 2.7.9.5, 2.8.11.3 or 2.9.7.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2018-14718 being exploited?

There is no known exploitation of CVE-2018-14718 in the wild and no public exploit code.

All Debian Debian Linux vulnerabilities

Sources

Also known as CLEANSTART-2026-UN12720, DEBIAN-CVE-2018-14718, GHSA-645p-88qh-w398, ROOT-APP-MAVEN-CVE-2018-14718, UBUNTU-CVE-2018-14718.

Is CVE-2018-14718 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free