CVE-2018-14719 Arbitrary Code Execution in jackson-databind
Remote attackers can execute arbitrary code via unsafe polymorphic deserialization in the jackson-databind library.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2018-14719?
CVE-2018-14719 is a critical unsafe deserialization vulnerability in Debian Debian Linux, published on 2 Jan 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
FasterXML jackson-databind 2.x before 2.9.7 might allow remote attackers to execute arbitrary code by leveraging failure to block the blaze-ds-opt and blaze-ds-core classes from polymorphic deserialization.
Weakness: CWE-502
Which versions are affected by CVE-2018-14719?
6 open source packages ship an affected version, including com.fasterxml.jackson.core:jackson-databind. It affects 20 products.
| Package | Affected | Fixed in |
|---|---|---|
com.fasterxml.jackson.core:jackson-databind Maven | From 2.0.0 | 2.7.9.5 |
com.fasterxml.jackson.core:jackson-databind Maven | From 2.0.0 | 2.7.9.5 |
com.fasterxml.jackson.core:jackson-databind Maven | From 2.8.0 | 2.8.11.3 |
com.fasterxml.jackson.core:jackson-databind Maven | From 2.8.0 | 2.8.11.3 |
com.fasterxml.jackson.core:jackson-databind Maven | From 2.9.0 | 2.9.7 |
com.fasterxml.jackson.core:jackson-databind Maven | From 2.9.0 | 2.9.7 |
Products include Debian Debian Linux, Fasterxml Jackson-Databind, Netapp Oncommand Workflow Automation, Netapp Snapcenter, Netapp Steelstore Cloud Integrated Storage, Oracle Banking Platform and 14 more.
How do I fix CVE-2018-14719?
Upgrade com.fasterxml.jackson.core:jackson-databind to a fixed version for your release line: 2.7.9.5, 2.8.11.3 or 2.9.7.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2018-14719 being exploited?
There is no known exploitation of CVE-2018-14719 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as CLEANSTART-2026-LL55019, DEBIAN-CVE-2018-14719, GHSA-4gq5-ch57-c2mg, ROOT-APP-MAVEN-CVE-2018-14719, UBUNTU-CVE-2018-14719.