CVE-2018-14721 Server-Side Request Forgery (SSRF) in jackson-databind

Critical 10.0 Published Updated

Remote attackers can perform Server-Side Request Forgery attacks by exploiting unsafe polymorphic deserialization in the jackson-databind library.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2018-14721?

CVE-2018-14721 is a critical server-side request forgery vulnerability in Debian Debian Linux, published on 2 Jan 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

FasterXML jackson-databind 2.x before 2.9.7 might allow remote attackers to conduct server-side request forgery (SSRF) attacks by leveraging failure to block the axis2-jaxws class from polymorphic deserialization.

Weakness: CWE-918

Which versions are affected by CVE-2018-14721?

6 open source packages ship an affected version, including com.fasterxml.jackson.core:jackson-databind. It affects 12 products.

PackageAffectedFixed in
com.fasterxml.jackson.core:jackson-databind MavenFrom 2.7.02.7.9.5
com.fasterxml.jackson.core:jackson-databind MavenFrom 2.7.02.7.9.5
com.fasterxml.jackson.core:jackson-databind MavenFrom 2.8.02.8.11.3
com.fasterxml.jackson.core:jackson-databind MavenFrom 2.8.02.8.11.3
com.fasterxml.jackson.core:jackson-databind MavenFrom 2.9.02.9.7
com.fasterxml.jackson.core:jackson-databind MavenFrom 2.9.02.9.7

Products include Debian Debian Linux, Fasterxml Jackson-Databind, Oracle Banking Platform, Oracle Communications Billing and Revenue Management, Oracle Enterprise Manager for Virtualization, Oracle Financial Services Analytical Applications Infrastructure and 6 more.

How do I fix CVE-2018-14721?

Upgrade com.fasterxml.jackson.core:jackson-databind to a fixed version for your release line: 2.7.9.5, 2.8.11.3 or 2.9.7.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2018-14721 being exploited?

There is no known exploitation of CVE-2018-14721 in the wild and no public exploit code.

All Debian Debian Linux vulnerabilities

Sources

Also known as CLEANSTART-2026-WO77133, DEBIAN-CVE-2018-14721, GHSA-9mxf-g3x6-wv74, UBUNTU-CVE-2018-14721.

Is CVE-2018-14721 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free