# CVE-2018-14731: Missing Origin Validation in parcel-bundler

> Attackers can steal developer code by connecting to the Parcel HMR WebSocket server from any origin due to missing origin checks.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Sep 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-37q6-576q-vgr7

## What is CVE-2018-14731?

CVE-2018-14731 is a high-severity vulnerability in n/a, published on 21 Sep 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in HMRServer.js in Parcel parcel-bundler. Attackers are able to steal developer's code because the origin of requests is not checked by the WebSocket server, which is used for HMR (Hot Module Replacement). Anyone can receive the HMR message sent by the WebSocket server via a ws://127.0.0.1 connection (with a random TCP port number) from any origin. The random port number can be found by connecting to http://127.0.0.1 and reading the "new WebSocket" line in the source code.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2018-14731?

2 open source packages ship an affected version, including parcel-bundler. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parcel-bundler` | npm | All versions | 1.10.0 |
| `parcel-bundler` | npm | All versions | 1.10.0 |

Products: Parceljs Parcel.

## How do I fix CVE-2018-14731?

Upgrade parcel-bundler to 1.10.0 or later.

## Is CVE-2018-14731 being exploited?

There is no known exploitation of CVE-2018-14731 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2025-56648](https://insights.sbomify.com/CVE-2025-56648/): Parcel has an Origin Validation Error vulnerability (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-14731 and fix it if it is affected.

What it is: CVE-2018-14731 is a high-severity vulnerability in n/a, published on 21 Sep 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-14731 in the wild and no public exploit code.

Affected packages and fixed versions:
- parcel-bundler (npm): affected all versions; fixed in 1.10.0
- parcel-bundler (npm): affected all versions; fixed in 1.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-14731/ (Markdown: https://insights.sbomify.com/CVE-2018-14731/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-14731
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-14731
- OSV: https://osv.dev/vulnerability/CVE-2018-14731

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-14731/
Summaries are generated and may contain mistakes; the official description above is the record.
