CVE-2018-14773 Symfony HTTP Foundation web cache poisoning
Attackers can bypass security controls or poison caches by spoofing request paths via legacy IIS headers in Symfony HttpFoundation.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2018-14773?
CVE-2018-14773 is a medium-severity vulnerability in Debian Debian Linux, published on 3 Aug 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue was discovered in Http Foundation in Symfony 2.7.0 through 2.7.48, 2.8.0 through 2.8.43, 3.3.0 through 3.3.17, 3.4.0 through 3.4.13, 4.0.0 through 4.0.13, and 4.1.0 through 4.1.2. It arises from support for a (legacy) IIS header that lets users override the path in the request URL via the X-Original-URL or X-Rewrite-URL HTTP request header. These headers are designed for IIS support, but it's not verified that the server is in fact running IIS, which means anybody who can send these requests to an application can trigger this. This affects \Symfony\Component\HttpFoundation\Request::prepareRequestUri() where X-Original-URL and X_REWRITE_URL are both used. The fix drops support for these methods so that they cannot be used as attack vectors such as web cache poisoning.
Which versions are affected by CVE-2018-14773?
24 open source packages ship an affected version, including symfony/http-foundation and symfony/symfony. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
symfony/http-foundation Packagist | From 2.7.0 | 2.7.49 |
symfony/http-foundation Packagist | From 2.7.0 | 2.7.49 |
symfony/http-foundation Packagist | From 2.8.0 | 2.8.44 |
symfony/http-foundation Packagist | From 2.8.0 | 2.8.44 |
symfony/http-foundation Packagist | From 3.0.0 | 3.3.18 |
symfony/http-foundation Packagist | From 3.0.0 | 3.3.18 |
18 more packages
symfony/http-foundation Packagist | From 3.4.0 | 3.4.14 |
symfony/http-foundation Packagist | From 3.4.0 | 3.4.14 |
symfony/http-foundation Packagist | From 4.0.0 | 4.0.14 |
symfony/http-foundation Packagist | From 4.0.0 | 4.0.14 |
symfony/http-foundation Packagist | From 4.1.0 | 4.1.3 |
symfony/http-foundation Packagist | From 4.1.0 | 4.1.3 |
symfony/symfony Packagist | From 2.7.0 | 2.7.49 |
symfony/symfony Packagist | From 2.7.0 | 2.7.49 |
symfony/symfony Packagist | From 2.8.0 | 2.8.44 |
symfony/symfony Packagist | From 2.8.0 | 2.8.44 |
symfony/symfony Packagist | From 3.0.0 | 3.3.18 |
symfony/symfony Packagist | From 3.0.0 | 3.3.18 |
symfony/symfony Packagist | From 3.4.0 | 3.4.14 |
symfony/symfony Packagist | From 3.4.0 | 3.4.14 |
symfony/symfony Packagist | From 4.0.0 | 4.0.14 |
symfony/symfony Packagist | From 4.0.0 | 4.0.14 |
symfony/symfony Packagist | From 4.1.0 | 4.1.3 |
symfony/symfony Packagist | From 4.1.0 | 4.1.3 |
Products include Debian Debian Linux, Drupal Drupal, Sensiolabs Symfony.
How do I fix CVE-2018-14773?
Upgrade symfony/http-foundation to a fixed version for your release line: 2.7.49, 2.8.44, 3.3.18 or 3.4.14.
Is CVE-2018-14773 being exploited?
There is no known exploitation of CVE-2018-14773 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2018-14773, GHSA-8wgj-6wx8-h5hq, UBUNTU-CVE-2018-14773.