# CVE-2018-14773: Symfony HTTP Foundation web cache poisoning

> Attackers can bypass security controls or poison caches by spoofing request paths via legacy IIS headers in Symfony HttpFoundation.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Aug 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-14773, GHSA-8wgj-6wx8-h5hq, UBUNTU-CVE-2018-14773

## What is CVE-2018-14773?

CVE-2018-14773 is a medium-severity vulnerability in Debian Debian Linux, published on 3 Aug 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue was discovered in Http Foundation in Symfony 2.7.0 through 2.7.48, 2.8.0 through 2.8.43, 3.3.0 through 3.3.17, 3.4.0 through 3.4.13, 4.0.0 through 4.0.13, and 4.1.0 through 4.1.2. It arises from support for a (legacy) IIS header that lets users override the path in the request URL via the X-Original-URL or X-Rewrite-URL HTTP request header. These headers are designed for IIS support, but it's not verified that the server is in fact running IIS, which means anybody who can send these requests to an application can trigger this. This affects \Symfony\Component\HttpFoundation\Request::prepareRequestUri() where X-Original-URL and X_REWRITE_URL are both used. The fix drops support for these methods so that they cannot be used as attack vectors such as web cache poisoning.

## Which versions are affected by CVE-2018-14773?

24 open source packages ship an affected version, including symfony/http-foundation and symfony/symfony. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `symfony/http-foundation` | Packagist | From 2.7.0 | 2.7.49 |
| `symfony/http-foundation` | Packagist | From 2.7.0 | 2.7.49 |
| `symfony/http-foundation` | Packagist | From 2.8.0 | 2.8.44 |
| `symfony/http-foundation` | Packagist | From 2.8.0 | 2.8.44 |
| `symfony/http-foundation` | Packagist | From 3.0.0 | 3.3.18 |
| `symfony/http-foundation` | Packagist | From 3.0.0 | 3.3.18 |
| `symfony/http-foundation` | Packagist | From 3.4.0 | 3.4.14 |
| `symfony/http-foundation` | Packagist | From 3.4.0 | 3.4.14 |
| `symfony/http-foundation` | Packagist | From 4.0.0 | 4.0.14 |
| `symfony/http-foundation` | Packagist | From 4.0.0 | 4.0.14 |
| `symfony/http-foundation` | Packagist | From 4.1.0 | 4.1.3 |
| `symfony/http-foundation` | Packagist | From 4.1.0 | 4.1.3 |
| `symfony/symfony` | Packagist | From 2.7.0 | 2.7.49 |
| `symfony/symfony` | Packagist | From 2.7.0 | 2.7.49 |
| `symfony/symfony` | Packagist | From 2.8.0 | 2.8.44 |
| `symfony/symfony` | Packagist | From 2.8.0 | 2.8.44 |
| `symfony/symfony` | Packagist | From 3.0.0 | 3.3.18 |
| `symfony/symfony` | Packagist | From 3.0.0 | 3.3.18 |
| `symfony/symfony` | Packagist | From 3.4.0 | 3.4.14 |
| `symfony/symfony` | Packagist | From 3.4.0 | 3.4.14 |
| `symfony/symfony` | Packagist | From 4.0.0 | 4.0.14 |
| `symfony/symfony` | Packagist | From 4.0.0 | 4.0.14 |
| `symfony/symfony` | Packagist | From 4.1.0 | 4.1.3 |
| `symfony/symfony` | Packagist | From 4.1.0 | 4.1.3 |

Products: Debian Debian Linux, Drupal Drupal, Sensiolabs Symfony.

## How do I fix CVE-2018-14773?

Upgrade symfony/http-foundation to a fixed version for your release line: 2.7.49, 2.8.44, 3.3.18 or 3.4.14.

## Is CVE-2018-14773 being exploited?

There is no known exploitation of CVE-2018-14773 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-14773 and fix it if it is affected.

What it is: CVE-2018-14773 is a medium-severity vulnerability in Debian Debian Linux, published on 3 Aug 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-14773 in the wild and no public exploit code.

Affected packages and fixed versions:
- symfony/http-foundation (Packagist): affected from 2.7.0; fixed in 2.7.49
- symfony/http-foundation (Packagist): affected from 2.7.0; fixed in 2.7.49
- symfony/http-foundation (Packagist): affected from 2.8.0; fixed in 2.8.44
- symfony/http-foundation (Packagist): affected from 2.8.0; fixed in 2.8.44
- symfony/http-foundation (Packagist): affected from 3.0.0; fixed in 3.3.18
- symfony/http-foundation (Packagist): affected from 3.0.0; fixed in 3.3.18
- symfony/http-foundation (Packagist): affected from 3.4.0; fixed in 3.4.14
- symfony/http-foundation (Packagist): affected from 3.4.0; fixed in 3.4.14
- symfony/http-foundation (Packagist): affected from 4.0.0; fixed in 4.0.14
- symfony/http-foundation (Packagist): affected from 4.0.0; fixed in 4.0.14
- symfony/http-foundation (Packagist): affected from 4.1.0; fixed in 4.1.3
- symfony/http-foundation (Packagist): affected from 4.1.0; fixed in 4.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-14773/ (Markdown: https://insights.sbomify.com/CVE-2018-14773/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-14773
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-14773
- OSV: https://osv.dev/vulnerability/CVE-2018-14773

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-14773/
Summaries are generated and may contain mistakes; the official description above is the record.
