CVE-2018-14774 Symfony Host Header Injection
Attackers can inject host headers in Symfony HttpCache due to implicit trust in X-Forwarded-Host, potentially bypassing security controls.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2018-14774?
CVE-2018-14774 is a high-severity vulnerability in Sensiolabs Symfony, published on 3 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in HttpKernel in Symfony 2.7.0 through 2.7.48, 2.8.0 through 2.8.43, 3.3.0 through 3.3.17, 3.4.0 through 3.4.13, 4.0.0 through 4.0.13, and 4.1.0 through 4.1.2. When using HttpCache, the values of the X-Forwarded-Host headers are implicitly set as trusted while this should be forbidden, leading to potential host header injection.
Weakness: CWE-20
Which versions are affected by CVE-2018-14774?
12 open source packages ship an affected version, including symfony/symfony. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
symfony/symfony Packagist | From 2.7.0 | 2.7.49 |
symfony/symfony Packagist | From 2.7.0 | 2.7.49 |
symfony/symfony Packagist | From 2.8.0 | 2.8.44 |
symfony/symfony Packagist | From 2.8.0 | 2.8.44 |
symfony/symfony Packagist | From 3.3.0 | 3.3.18 |
symfony/symfony Packagist | From 3.3.0 | 3.3.18 |
6 more packages
symfony/symfony Packagist | From 3.4.0 | 3.4.14 |
symfony/symfony Packagist | From 3.4.0 | 3.4.14 |
symfony/symfony Packagist | From 4.0.0 | 4.0.14 |
symfony/symfony Packagist | From 4.0.0 | 4.0.14 |
symfony/symfony Packagist | From 4.1.0 | 4.1.3 |
symfony/symfony Packagist | From 4.1.0 | 4.1.3 |
Products include Sensiolabs Symfony.
How do I fix CVE-2018-14774?
Upgrade symfony/symfony to a fixed version for your release line: 2.7.49, 2.8.44, 3.3.18 or 3.4.14.
Is CVE-2018-14774 being exploited?
There is no known exploitation of CVE-2018-14774 in the wild and no public exploit code.
Other vulnerabilities in Sensiolabs Symfony
Sources
Also known as DEBIAN-CVE-2018-14774, GHSA-66p6-7p29-55p9, UBUNTU-CVE-2018-14774.