{"answers":{"affected":"It affects 2 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2018-14912 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2018-14912 is a high-severity path traversal vulnerability in Debian Debian Linux, published on 3 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-14912 and fix it if it is affected.\n\nWhat it is: CVE-2018-14912 is a high-severity path traversal vulnerability in Debian Debian Linux, published on 3 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2018-14912 exists.\n\nAffected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-14912/ (Markdown: https://insights.sbomify.com/CVE-2018-14912/index.md)","id":"CVE-2018-14912","markdown":"https://insights.sbomify.com/CVE-2018-14912/index.md","name":"CVE-2018-14912","record":{"aliases":["ALPINE-CVE-2018-14912","DEBIAN-CVE-2018-14912","DLA-1459-1","DSA-4263-1","GHSA-46c3-xc8j-9qg7","MGASA-2018-0351","UBUNTU-CVE-2018-14912","USN-8757-1","openSUSE-SU-2024:10679-1"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"CGit web interface","requires_auth":"none","summary":"An attacker can read arbitrary files via directory traversal in CGit when HTTP cloning is enabled, requiring an upgrade to fix.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"cgit","vendor":"cgit_project"},{"product":"debian_linux","vendor":"debian"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"cgit_clone_objects in CGit before 1.2.1 has a directory traversal vulnerability when `enable-http-clone=1` is not turned off, as demonstrated by a cgit/cgit.cgi/git/objects/?path=../ request.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":1,"first_seen":"2018-08-03","github_poc":0,"max_poc_stars":null,"metasploit":1,"nuclei":1,"refs":[{"date":"2018-08-03","kind":"metasploit","ref":"auxiliary/scanner/http/cgit_traversal","stars":null,"title":"cgit Directory Traversal"},{"date":"2018-08-14","kind":"exploitdb","ref":"45195","stars":null,"title":"cgit 1.2.1 - Directory Traversal (Metasploit)"},{"date":null,"kind":"nuclei","ref":"http/cves/2018/CVE-2018-14912.yaml","stars":null,"title":"cgit \u003c 1.2.1 - Directory Traversal"}],"tier":"weaponised"},"has_fix":true,"headline":"Path traversal in n/a","id":"CVE-2018-14912","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"debian:debian_linux","products":["debian:debian_linux"],"type":"path_traversal","year":"2018"},"n_packages":1,"n_references":5,"next":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2018-14915"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.2.3-1.10"],"introduced":["0"],"last_affected":[],"package":"cgit","purl":"pkg:rpm/opensuse/cgit\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:10679-1"}],"prev":{"headline":"File upload in n/a","id":"CVE-2018-14911"},"products":["n/a"],"published":"2018-08-03","related":[{"cvss_score":9.8,"headline":"Integer overflow in n/a","id":"CVE-2016-1901","kev_date_added":null,"published":"2016-01-20"},{"cvss_score":3.7,"headline":"Cross-site scripting in n/a","id":"CVE-2016-1899","kev_date_added":null,"published":"2016-01-20"},{"cvss_score":3.7,"headline":"Cross-site scripting in n/a","id":"CVE-2016-1900","kev_date_added":null,"published":"2016-01-20"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"BSD-3-Clause","name":"Metasploit"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"An attacker can read arbitrary files via directory traversal in CGit when HTTP cloning is enabled, requiring an upgrade to fix.","url":"https://insights.sbomify.com/CVE-2018-14912/"}