{"answers":{"affected":"It affects 3 products.","exploited":"There is no known exploitation of CVE-2018-15471 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2018-15471 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 17 Aug 2018. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-15471 and fix it if it is affected.\n\nWhat it is: CVE-2018-15471 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 17 Aug 2018. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-15471 in the wild and no public exploit code.\n\nAffected product: Canonical Ubuntu Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-15471/ (Markdown: https://insights.sbomify.com/CVE-2018-15471/index.md)","id":"CVE-2018-15471","markdown":"https://insights.sbomify.com/CVE-2018-15471/index.md","name":"CVE-2018-15471","record":{"aliases":["DEBIAN-CVE-2018-15471","GHSA-qv83-77rj-635j","SUSE-SU-2018:2677-1","UBUNTU-CVE-2018-15471"],"analysis":{"component_type":"kernel","fix_type":"patch","impacts":["privilege_escalation","denial_of_service","data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Linux kernel netback","requires_auth":"low_privilege","summary":"A missing integer overflow check in the Linux kernel netback driver allows malicious frontends to trigger out-of-bounds memory access, leading to privilege escalation, DoS, or information leaks.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ubuntu_linux","vendor":"canonical"},{"product":"linux_kernel","vendor":"linux"},{"product":"xen","vendor":"xen"}],"cvss":{"score":7.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-125","name":"Out-of-bounds Read"}],"description":"An issue was discovered in xenvif_set_hash_mapping in drivers/net/xen-netback/hash.c in the Linux kernel through 4.18.1, as used in Xen through 4.11.x and other products. The Linux netback driver allows frontends to control mapping of requests to request queues. When processing a request to set or change this mapping, some input validation (e.g., for an integer overflow) was missing or flawed, leading to OOB access in hash handling. A malicious or buggy frontend may cause the (usually privileged) backend to make out of bounds memory accesses, potentially resulting in one or more of privilege escalation, Denial of Service (DoS), or information leaks.","ecosystems":["SUSE:Linux Enterprise Live Patching 15"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Integer overflow in n/a","id":"CVE-2018-15471","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux","linux:linux_kernel","xen:xen"],"type":"integer_overflow","year":"2018"},"n_packages":2,"n_references":8,"next":{"headline":"Denial of service in n/a","id":"CVE-2018-15472"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Live Patching 15","fixed":["3-7.3"],"introduced":["0"],"last_affected":[],"package":"kernel-livepatch-SLE15_Update_0","purl":"pkg:rpm/suse/kernel-livepatch-SLE15_Update_0\u0026distro=SUSE%20Linux%20Enterprise%20Live%20Patching%2015","source":"SUSE-SU-2018:2677-1"},{"ecosystem":"SUSE:Linux Enterprise Live Patching 15","fixed":["3-2.1"],"introduced":["0"],"last_affected":[],"package":"kernel-livepatch-SLE15_Update_1","purl":"pkg:rpm/suse/kernel-livepatch-SLE15_Update_1\u0026distro=SUSE%20Linux%20Enterprise%20Live%20Patching%2015","source":"SUSE-SU-2018:2677-1"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2018-15470"},"products":["n/a"],"published":"2018-08-17","related":[{"cvss_score":9.8,"headline":"SaltStack Salt Authentication Bypass","id":"CVE-2020-11651","kev_date_added":"2021-11-03","published":"2020-04-30"},{"cvss_score":9.8,"headline":"OpenSMTPD Remote Code Execution","id":"CVE-2020-7247","kev_date_added":"2022-03-25","published":"2020-01-29"},{"cvss_score":9.8,"headline":"Exim Out-of-bounds Write","id":"CVE-2019-16928","kev_date_added":"2022-03-03","published":"2019-09-27"},{"cvss_score":9.8,"headline":"Exim Buffer Overflow","id":"CVE-2018-6789","kev_date_added":"2021-11-03","published":"2018-02-08"},{"cvss_score":9.8,"headline":"Oracle Java SE and Java SE Embedded Remote Code Execution","id":"CVE-2015-2590","kev_date_added":"2022-03-03","published":"2015-07-16"},{"cvss_score":9.8,"headline":"Oracle JRE Remote Code Execution","id":"CVE-2013-0422","kev_date_added":"2022-05-25","published":"2013-01-10"},{"cvss_score":9.8,"headline":"Oracle Java SE Runtime Environment (JRE) Arbitrary Code Execution","id":"CVE-2011-3544","kev_date_added":"2022-03-03","published":"2011-10-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"A missing integer overflow check in the Linux kernel netback driver allows malicious frontends to trigger out-of-bounds memory access, leading to privilege escalation, DoS, or information leaks.","url":"https://insights.sbomify.com/CVE-2018-15471/"}