# CVE-2018-15491: Security feature bypass in n/a

> Attackers can bypass whitelisting protections in Zemana Anti-Logger to execute unauthorized applications, including keyloggers, by manipulating local configuration files.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 18 Aug 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-2wfx-593f-j3xw

## What is CVE-2018-15491?

CVE-2018-15491 is a high-severity vulnerability in n/a, published on 18 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability in the permission and encryption implementation of Zemana Anti-Logger 1.9.3.527 and prior (fixed in 1.9.3.602) allows an attacker to take control of the whitelisting feature (MyRules2.ini under %LOCALAPPDATA%\Zemana\ZALSDK) to permit execution of unauthorized applications (such as ones that record keystrokes).

Weakness: CWE-798 (Use of Hard-coded Credentials), CWE-732 (Incorrect Permission Assignment for Critical Resource)

## Which versions are affected by CVE-2018-15491?

It affects 1 product.


Products: Zemana Antilogger.

## How do I fix CVE-2018-15491?

No fix has been published for CVE-2018-15491 yet. Limit exposure of the affected software until one is available.

## Is CVE-2018-15491 being exploited?

There is no known exploitation of CVE-2018-15491 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2024-2180](https://insights.sbomify.com/CVE-2024-2180/): Zemana AntiLogger v2.74.204.664 - Kernel Memory Leak (medium 5.5)
- [CVE-2024-2204](https://insights.sbomify.com/CVE-2024-2204/): Zemana AntiLogger v2.74.204.664 - Denial of Service (DoS) (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-15491 and fix it if it is affected.

What it is: CVE-2018-15491 is a high-severity vulnerability in n/a, published on 18 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-15491 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-15491/ (Markdown: https://insights.sbomify.com/CVE-2018-15491/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-15491
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-15491
- OSV: https://osv.dev/vulnerability/CVE-2018-15491

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-15491/
Summaries are generated and may contain mistakes; the official description above is the record.
