{"answers":{"affected":"3 open source packages ship an affected version, including pycryptodome. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-15560 in the wild and no public exploit code.","fix":"Upgrade pycryptodome to 3.6.6 or later.","what":"CVE-2018-15560 is a high-severity vulnerability in n/a, published on 20 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-15560 and fix it if it is affected.\n\nWhat it is: CVE-2018-15560 is a high-severity vulnerability in n/a, published on 20 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-15560 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pycryptodome (PyPI): affected all versions; fixed in 3.6.6\n- pycryptodome (PyPI): affected all versions; fixed in 3.6.6\n- pycryptodome (PyPI): affected all versions; fixed in 3.6.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-15560/ (Markdown: https://insights.sbomify.com/CVE-2018-15560/index.md)","id":"CVE-2018-15560","markdown":"https://insights.sbomify.com/CVE-2018-15560/index.md","name":"CVE-2018-15560","record":{"aliases":["GHSA-hgg3-g7gr-66r7","PYSEC-2018-21"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["other"],"network_reachable":"yes","non_default_config":false,"product_category":"Python cryptography library","requires_auth":"none","summary":"An integer overflow in PyCryptodome mishandles short messages, potentially causing incorrect encryption or decryption behavior.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"pycryptodome","vendor":"pycryptodome"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-190","name":"Integer Overflow or Wraparound"}],"description":"PyCryptodome before 3.6.6 has an integer overflow in the data_len variable in AESNI.c, related to the AESNI_encrypt and AESNI_decrypt functions, leading to the mishandling of messages shorter than 16 bytes.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PyCryptodome integer overflow vulnerability","id":"CVE-2018-15560","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"integer_overflow","year":"2018"},"n_packages":3,"n_references":2,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2018-15562"},"packages":[{"ecosystem":"PyPI","fixed":["3.6.6"],"introduced":["0"],"last_affected":[],"package":"pycryptodome","purl":null,"source":"GHSA-hgg3-g7gr-66r7"},{"ecosystem":"PyPI","fixed":["3.6.6"],"introduced":["0"],"last_affected":[],"package":"pycryptodome","purl":"pkg:pypi/pycryptodome","source":"GHSA-hgg3-g7gr-66r7"},{"ecosystem":"PyPI","fixed":["3.6.6"],"introduced":["0"],"last_affected":[],"package":"pycryptodome","purl":"pkg:pypi/pycryptodome","source":"PYSEC-2018-21"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2018-15559"},"products":["n/a"],"published":"2018-08-20","related":[{"cvss_score":5.9,"headline":"PyCryptodome and pycryptodomex side-channel leakage for OAEP decryption","id":"CVE-2023-52323","kev_date_added":null,"published":"2024-01-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"An integer overflow in PyCryptodome mishandles short messages, potentially causing incorrect encryption or decryption behavior.","url":"https://insights.sbomify.com/CVE-2018-15560/"}