# CVE-2018-15696: Information disclosure in ASUSTOR Data Master

> Authenticated non-admin users can enumerate all user accounts in ASUSTOR Data Master, exposing sensitive user information.

- **Severity:** Medium 4.3 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 27 Aug 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-9f38-jj5w-25cg

## What is CVE-2018-15696?

CVE-2018-15696 is a medium-severity vulnerability in Tenable ASUSTOR Data Master, published on 27 Aug 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

ASUSTOR Data Master 3.1.5 and below allows authenticated remote non-administrative users to enumerate all user accounts via user.cgi.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2018-15696?

It affects 1 product.


Products: Asustor Data Master.

## How do I fix CVE-2018-15696?

No fix has been published for CVE-2018-15696 yet. Limit exposure of the affected software until one is available.

## Is CVE-2018-15696 being exploited?

There is no known exploitation of CVE-2018-15696 in the wild and no public exploit code.

## Other vulnerabilities in Tenable ASUSTOR Data Master

- [CVE-2018-12313](https://insights.sbomify.com/CVE-2018-12313/): Command injection in n/a (critical 9.8)
- [CVE-2026-24936](https://insights.sbomify.com/CVE-2026-24936/): An improper input validation vulnerability was found in ADM while joining a AD Domain. (critical 9.5)
- [CVE-2026-6644](https://insights.sbomify.com/CVE-2026-6644/): A command injection vulnerability was found in the PPTP VPN Clients on the ADM (critical 9.4)
- [CVE-2026-3179](https://insights.sbomify.com/CVE-2026-3179/): A path traversal vulnerability was found in the FTP Backup on the ADM. (critical 9.2)
- [CVE-2026-24932](https://insights.sbomify.com/CVE-2026-24932/): An improper certificate validation vulnerability was found in ADM while updating the DDNS settings. (high 8.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-15696 and fix it if it is affected.

What it is: CVE-2018-15696 is a medium-severity vulnerability in Tenable ASUSTOR Data Master, published on 27 Aug 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-15696 in the wild and no public exploit code.

Affected product: Tenable ASUSTOR Data Master. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-15696/ (Markdown: https://insights.sbomify.com/CVE-2018-15696/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-15696
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-15696
- OSV: https://osv.dev/vulnerability/CVE-2018-15696

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-15696/
Summaries are generated and may contain mistakes; the official description above is the record.
