CVE-2018-15756 DoS Attack via Range Requests
Attackers can cause denial of service in Spring Framework applications by sending malicious range headers to static resource handlers.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2018-15756?
CVE-2018-15756 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 18 Oct 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Spring Framework, version 5.1, versions 5.0.x prior to 5.0.10, versions 4.3.x prior to 4.3.20, and older unsupported versions on the 4.2.x branch provide support for range requests when serving static resources through the ResourceHttpRequestHandler, or starting in 5.0 when an annotated controller returns an org.springframework.core.io.Resource. A malicious user (or attacker) can add a range header with a high number of ranges, or with wide ranges that overlap, or both, for a denial of service attack. This vulnerability affects applications that depend on either spring-webmvc or spring-webflux. Such applications must also have a registration for serving static resources (e.g. JS, CSS, images, and others), or have an annotated controller that returns an org.springframework.core.io.Resource. Spring Boot applications that depend on spring-boot-starter-web or spring-boot-starter-webflux are ready to serve static resources out of the box and are therefore vulnerable.
Which versions are affected by CVE-2018-15756?
6 open source packages ship an affected version, including org.springframework:spring-core. It affects 40 products.
| Package | Affected | Fixed in |
|---|---|---|
org.springframework:spring-core Maven | From 4.2.0.RELEASE | 4.3.20.RELEASE |
org.springframework:spring-core Maven | From 4.2.0.RELEASE | 4.3.20.RELEASE |
org.springframework:spring-core Maven | From 5.0.0.RELEASE | 5.0.10.RELEASE |
org.springframework:spring-core Maven | From 5.0.0.RELEASE | 5.0.10.RELEASE |
org.springframework:spring-core Maven | From 5.1.0.RELEASE | 5.1.1.RELEASE |
org.springframework:spring-core Maven | From 5.1.0.RELEASE | 5.1.1.RELEASE |
Products include Debian Debian Linux, Oracle Agile Product Lifecycle Management, Oracle Communications Brm - Elastic Charging Engine, Oracle Communications Converged Application Server - Service Controller, Oracle Communications Diameter Signaling Router, Oracle Communications Element Manager and 34 more.
How do I fix CVE-2018-15756?
Upgrade org.springframework:spring-core to a fixed version for your release line: 4.3.20.RELEASE, 5.0.10.RELEASE or 5.1.1.RELEASE.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2018-15756 being exploited?
There is no known exploitation of CVE-2018-15756 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2018-15756, GHSA-ffvq-7w96-97p7, UBUNTU-CVE-2018-15756.