# CVE-2018-15756: DoS Attack via Range Requests

> Attackers can cause denial of service in Spring Framework applications by sending malicious range headers to static resource handlers.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Oct 2018
- **Updated:** 8 Oct 2026
- **Also known as:** DEBIAN-CVE-2018-15756, GHSA-ffvq-7w96-97p7, UBUNTU-CVE-2018-15756

## What is CVE-2018-15756?

CVE-2018-15756 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 18 Oct 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Spring Framework, version 5.1, versions 5.0.x prior to 5.0.10, versions 4.3.x prior to 4.3.20, and older unsupported versions on the 4.2.x branch provide support for range requests when serving static resources through the ResourceHttpRequestHandler, or starting in 5.0 when an annotated controller returns an org.springframework.core.io.Resource. A malicious user (or attacker) can add a range header with a high number of ranges, or with wide ranges that overlap, or both, for a denial of service attack. This vulnerability affects applications that depend on either spring-webmvc or spring-webflux. Such applications must also have a registration for serving static resources (e.g. JS, CSS, images, and others), or have an annotated controller that returns an org.springframework.core.io.Resource. Spring Boot applications that depend on spring-boot-starter-web or spring-boot-starter-webflux are ready to serve static resources out of the box and are therefore vulnerable.

## Which versions are affected by CVE-2018-15756?

6 open source packages ship an affected version, including org.springframework:spring-core. It affects 40 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework:spring-core` | Maven | From 4.2.0.RELEASE | 4.3.20.RELEASE |
| `org.springframework:spring-core` | Maven | From 4.2.0.RELEASE | 4.3.20.RELEASE |
| `org.springframework:spring-core` | Maven | From 5.0.0.RELEASE | 5.0.10.RELEASE |
| `org.springframework:spring-core` | Maven | From 5.0.0.RELEASE | 5.0.10.RELEASE |
| `org.springframework:spring-core` | Maven | From 5.1.0.RELEASE | 5.1.1.RELEASE |
| `org.springframework:spring-core` | Maven | From 5.1.0.RELEASE | 5.1.1.RELEASE |

Products: Debian Debian Linux, Oracle Agile Product Lifecycle Management, Oracle Communications Brm - Elastic Charging Engine, Oracle Communications Converged Application Server - Service Controller, Oracle Communications Diameter Signaling Router, Oracle Communications Element Manager, Oracle Communications Online Mediation Controller, Oracle Communications Session Report Manager, Oracle Communications Session Route Manager, Oracle Communications Unified Inventory Management, Oracle Endeca Information Discovery Integrator, Oracle Enterprise Manager for Fusion Applications, Oracle Enterprise Manager Ops Center, Oracle Financial Services Analytical Applications Infrastructure, Oracle Flexcube Private Banking, Oracle Goldengate Application Adapters, Oracle Healthcare Master Person Index, Oracle Identity Manager Connector, Oracle Insurance Calculation Engine, Oracle Insurance Policy Administration J2ee and 20 more.

## How do I fix CVE-2018-15756?

Upgrade org.springframework:spring-core to a fixed version for your release line: 4.3.20.RELEASE, 5.0.10.RELEASE or 5.1.1.RELEASE.

## Is CVE-2018-15756 being exploited?

There is no known exploitation of CVE-2018-15756 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-15756 and fix it if it is affected.

What it is: CVE-2018-15756 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 18 Oct 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-15756 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework:spring-core (Maven): affected from 4.2.0.RELEASE; fixed in 4.3.20.RELEASE
- org.springframework:spring-core (Maven): affected from 4.2.0.RELEASE; fixed in 4.3.20.RELEASE
- org.springframework:spring-core (Maven): affected from 5.0.0.RELEASE; fixed in 5.0.10.RELEASE
- org.springframework:spring-core (Maven): affected from 5.0.0.RELEASE; fixed in 5.0.10.RELEASE
- org.springframework:spring-core (Maven): affected from 5.1.0.RELEASE; fixed in 5.1.1.RELEASE
- org.springframework:spring-core (Maven): affected from 5.1.0.RELEASE; fixed in 5.1.1.RELEASE

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-15756/ (Markdown: https://insights.sbomify.com/CVE-2018-15756/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-15756
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-15756
- OSV: https://osv.dev/vulnerability/CVE-2018-15756

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-15756/
Summaries are generated and may contain mistakes; the official description above is the record.
