CVE-2018-15758 Privilege Escalation in spring-security-oauth2

Critical 9.6 Published Updated

Attackers can escalate privileges by crafting requests to a custom approval endpoint in Spring Security OAuth applications configured with specific controller arguments.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2018-15758?

CVE-2018-15758 is a critical vulnerability in Pivotal Spring Security OAuth, published on 18 Oct 2018. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Spring Security OAuth, versions 2.3 prior to 2.3.4, and 2.2 prior to 2.2.3, and 2.1 prior to 2.1.3, and 2.0 prior to 2.0.16, and older unsupported versions could be susceptible to a privilege escalation under certain conditions. A malicious user or attacker can craft a request to the approval endpoint that can modify the previously saved authorization request and lead to a privilege escalation on the subsequent approval. This scenario can happen if the application is configured to use a custom approval endpoint that declares AuthorizationRequest as a controller method argument. This vulnerability exposes applications that meet all of the following requirements: Act in the role of an Authorization Server (e.g. @EnableAuthorizationServer) and use a custom Approval Endpoint that declares AuthorizationRequest as a controller method argument. This vulnerability does not expose applications that: Act in the role of an Authorization Server and use the default Approval Endpoint, act in the role of a Resource Server only (e.g. @EnableResourceServer), act in the role of a Client only (e.g. @EnableOAuthClient).

Which versions are affected by CVE-2018-15758?

8 open source packages ship an affected version, including org.springframework.security.oauth:spring-security-oauth2. It affects 1 product.

PackageAffectedFixed in
org.springframework.security.oauth:spring-security-oauth2 MavenFrom 2.0.02.0.16
org.springframework.security.oauth:spring-security-oauth2 MavenFrom 2.0.02.0.16
org.springframework.security.oauth:spring-security-oauth2 MavenFrom 2.1.02.1.3
org.springframework.security.oauth:spring-security-oauth2 MavenFrom 2.1.02.1.3
org.springframework.security.oauth:spring-security-oauth2 MavenFrom 2.2.02.2.3.RELEASE
org.springframework.security.oauth:spring-security-oauth2 MavenFrom 2.2.02.2.3.RELEASE
2 more packages
org.springframework.security.oauth:spring-security-oauth2 MavenFrom 2.3.02.3.4.RELEASE
org.springframework.security.oauth:spring-security-oauth2 MavenFrom 2.3.02.3.4.RELEASE

Products include Pivotal Software Spring Security Oauth.

How do I fix CVE-2018-15758?

Upgrade org.springframework.security.oauth:spring-security-oauth2 to a fixed version for your release line: 2.0.16, 2.1.3, 2.2.3.RELEASE or 2.3.4.RELEASE.

Is CVE-2018-15758 being exploited?

There is no known exploitation of CVE-2018-15758 in the wild and no public exploit code.

Sources

Also known as GHSA-h8w4-qv99-f7vj.

Is CVE-2018-15758 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free