# CVE-2018-15758: Privilege Escalation in spring-security-oauth2

> Attackers can escalate privileges by crafting requests to a custom approval endpoint in Spring Security OAuth applications configured with specific controller arguments.

- **Severity:** Critical 9.6 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Oct 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-h8w4-qv99-f7vj

## What is CVE-2018-15758?

CVE-2018-15758 is a critical vulnerability in Pivotal Spring Security OAuth, published on 18 Oct 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Spring Security OAuth, versions 2.3 prior to 2.3.4, and 2.2 prior to 2.2.3, and 2.1 prior to 2.1.3, and 2.0 prior to 2.0.16, and older unsupported versions could be susceptible to a privilege escalation under certain conditions. A malicious user or attacker can craft a request to the approval endpoint that can modify the previously saved authorization request and lead to a privilege escalation on the subsequent approval. This scenario can happen if the application is configured to use a custom approval endpoint that declares AuthorizationRequest as a controller method argument. This vulnerability exposes applications that meet all of the following requirements: Act in the role of an Authorization Server (e.g. @EnableAuthorizationServer) and use a custom Approval Endpoint that declares AuthorizationRequest as a controller method argument. This vulnerability does not expose applications that: Act in the role of an Authorization Server and use the default Approval Endpoint, act in the role of a Resource Server only (e.g. @EnableResourceServer), act in the role of a Client only (e.g. @EnableOAuthClient).

## Which versions are affected by CVE-2018-15758?

8 open source packages ship an affected version, including org.springframework.security.oauth:spring-security-oauth2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.security.oauth:spring-security-oauth2` | Maven | From 2.0.0 | 2.0.16 |
| `org.springframework.security.oauth:spring-security-oauth2` | Maven | From 2.0.0 | 2.0.16 |
| `org.springframework.security.oauth:spring-security-oauth2` | Maven | From 2.1.0 | 2.1.3 |
| `org.springframework.security.oauth:spring-security-oauth2` | Maven | From 2.1.0 | 2.1.3 |
| `org.springframework.security.oauth:spring-security-oauth2` | Maven | From 2.2.0 | 2.2.3.RELEASE |
| `org.springframework.security.oauth:spring-security-oauth2` | Maven | From 2.2.0 | 2.2.3.RELEASE |
| `org.springframework.security.oauth:spring-security-oauth2` | Maven | From 2.3.0 | 2.3.4.RELEASE |
| `org.springframework.security.oauth:spring-security-oauth2` | Maven | From 2.3.0 | 2.3.4.RELEASE |

Products: Pivotal Software Spring Security Oauth.

## How do I fix CVE-2018-15758?

Upgrade org.springframework.security.oauth:spring-security-oauth2 to a fixed version for your release line: 2.0.16, 2.1.3, 2.2.3.RELEASE or 2.3.4.RELEASE.

## Is CVE-2018-15758 being exploited?

There is no known exploitation of CVE-2018-15758 in the wild and no public exploit code.

## Other vulnerabilities in Pivotal Spring Security OAuth

- [CVE-2018-1260](https://insights.sbomify.com/CVE-2018-1260/): Spring Security OAuth vulnerable to remote code execution (RCE) (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-15758 and fix it if it is affected.

What it is: CVE-2018-15758 is a critical vulnerability in Pivotal Spring Security OAuth, published on 18 Oct 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-15758 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.security.oauth:spring-security-oauth2 (Maven): affected from 2.0.0; fixed in 2.0.16
- org.springframework.security.oauth:spring-security-oauth2 (Maven): affected from 2.0.0; fixed in 2.0.16
- org.springframework.security.oauth:spring-security-oauth2 (Maven): affected from 2.1.0; fixed in 2.1.3
- org.springframework.security.oauth:spring-security-oauth2 (Maven): affected from 2.1.0; fixed in 2.1.3
- org.springframework.security.oauth:spring-security-oauth2 (Maven): affected from 2.2.0; fixed in 2.2.3.RELEASE
- org.springframework.security.oauth:spring-security-oauth2 (Maven): affected from 2.2.0; fixed in 2.2.3.RELEASE
- org.springframework.security.oauth:spring-security-oauth2 (Maven): affected from 2.3.0; fixed in 2.3.4.RELEASE
- org.springframework.security.oauth:spring-security-oauth2 (Maven): affected from 2.3.0; fixed in 2.3.4.RELEASE

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-15758/ (Markdown: https://insights.sbomify.com/CVE-2018-15758/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-15758
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-15758
- OSV: https://osv.dev/vulnerability/CVE-2018-15758

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-15758/
Summaries are generated and may contain mistakes; the official description above is the record.
