# CVE-2018-15798: Pivotal Concourse allows malicious redirect urls on login

> Attackers can redirect users to malicious sites via OAuth login, potentially stealing access tokens and compromising user accounts.

- **Severity:** High 7.6 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Dec 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-9689-rx4v-cqgc

## What is CVE-2018-15798?

CVE-2018-15798 is a high-severity vulnerability in Pivotal Concourse, published on 19 Dec 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Pivotal Concourse Release, versions 4.x prior to 4.2.2, login flow allows redirects to untrusted websites. A remote unauthenticated attacker could convince a user to click on a link using the oAuth redirect link with an untrusted website and gain access to that user's access token in Concourse.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2018-15798?

6 open source packages ship an affected version, including github.com/concourse/concourse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/concourse/concourse` | Go | All versions | 5.2.8 |
| `github.com/concourse/concourse` | Go | All versions | 5.2.8 |
| `github.com/concourse/concourse` | Go | From 5.3.0 | 5.5.10 |
| `github.com/concourse/concourse` | Go | From 5.3.0 | 5.5.10 |
| `github.com/concourse/concourse` | Go | From 5.6.0 | 5.8.1 |
| `github.com/concourse/concourse` | Go | From 5.6.0 | 5.8.1 |

Products: Pivotal Software Concourse.

## How do I fix CVE-2018-15798?

Upgrade github.com/concourse/concourse to a fixed version for your release line: 5.2.8, 5.5.10 or 5.8.1.

## Is CVE-2018-15798 being exploited?

There is no known exploitation of CVE-2018-15798 in the wild and no public exploit code.

## Other vulnerabilities in Pivotal Concourse

- [CVE-2020-5415](https://insights.sbomify.com/CVE-2020-5415/): Concourse's GitLab auth allows impersonation (critical 10.0)
- [CVE-2020-5409](https://insights.sbomify.com/CVE-2020-5409/): Concourse Open Redirect in the /sky/login endpoint (high 7.6)
- [CVE-2018-1227](https://insights.sbomify.com/CVE-2018-1227/): Supply chain in Concourse CI: As of 2018-03-13, Pivotal does not believe that any resources or builds of Concourse have been compromised. (high 7.5)
- [CVE-2019-3792](https://insights.sbomify.com/CVE-2019-3792/): Concourse 5.0.0 SQL Injection vulnerability (medium 6.8)
- [CVE-2022-31683](https://insights.sbomify.com/CVE-2022-31683/): Team scope authorization bypass when Post/Put request with :team_name in body, allows HTTP parameter pollution (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-15798 and fix it if it is affected.

What it is: CVE-2018-15798 is a high-severity vulnerability in Pivotal Concourse, published on 19 Dec 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-15798 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/concourse/concourse (Go): affected all versions; fixed in 5.2.8
- github.com/concourse/concourse (Go): affected all versions; fixed in 5.2.8
- github.com/concourse/concourse (Go): affected from 5.3.0; fixed in 5.5.10
- github.com/concourse/concourse (Go): affected from 5.3.0; fixed in 5.5.10
- github.com/concourse/concourse (Go): affected from 5.6.0; fixed in 5.8.1
- github.com/concourse/concourse (Go): affected from 5.6.0; fixed in 5.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-15798/ (Markdown: https://insights.sbomify.com/CVE-2018-15798/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-15798
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-15798
- OSV: https://osv.dev/vulnerability/CVE-2018-15798

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-15798/
Summaries are generated and may contain mistakes; the official description above is the record.
