# CVE-2018-15801: Authorization Bypass During JWT Issuer Validation with spring-security

> Attackers can bypass authorization checks in Spring Security if a shared private key is used, allowing forged JWTs to be accepted as valid.

- **Severity:** Low 3.3 (`CVSS:3.0/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Dec 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-27xw-p8v6-9jjr

## What is CVE-2018-15801?

CVE-2018-15801 is a low-severity authentication bypass vulnerability in Vmware Spring Framework, published on 19 Dec 2018. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Spring Security versions 5.1.x prior to 5.1.2 contain an authorization bypass vulnerability during JWT issuer validation. In order to be impacted, the same private key for an honest issuer and a malicious user must be used when signing JWTs. In that case, a malicious user could fashion signed JWTs with the malicious issuer URL that may be granted for the honest issuer.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2018-15801?

4 open source packages ship an affected version, including org.springframework.security:spring-security-core and org.springframework.security:spring-security-oauth2-jose. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.security:spring-security-core` | Maven | From 5.1.0 | 5.1.2 |
| `org.springframework.security:spring-security-core` | Maven | From 5.1.0 | 5.1.2 |
| `org.springframework.security:spring-security-oauth2-jose` | Maven | From 5.1.0 | 5.1.2 |
| `org.springframework.security:spring-security-oauth2-jose` | Maven | From 5.1.0 | 5.1.2 |

Products: Vmware Spring Framework.

## How do I fix CVE-2018-15801?

Upgrade org.springframework.security:spring-security-core to 5.1.2 or later.

## Is CVE-2018-15801 being exploited?

There is no known exploitation of CVE-2018-15801 in the wild and no public exploit code.

## Other vulnerabilities in Vmware Spring Framework

- [CVE-2026-47884](https://insights.sbomify.com/CVE-2026-47884/): Spring Framework Improper Path Limitation in XsltView (critical 9.8)
- [CVE-2026-47890](https://insights.sbomify.com/CVE-2026-47890/): Spring Framework Server Sent Event stream corruption while rendering fragments (critical 9.8)
- [CVE-2026-47891](https://insights.sbomify.com/CVE-2026-47891/): Spring Framework maxInMemorySize Bypassed in Jaxb2Decoder (critical 9.8)
- [CVE-2026-47892](https://insights.sbomify.com/CVE-2026-47892/): Spring Framework Header Predicate Bypass in WebFlux Functional Endpoints (critical 9.8)
- [CVE-2026-59313](https://insights.sbomify.com/CVE-2026-59313/): Server Sent Event stream corruption in Spring MVC functional web framework (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-15801 and fix it if it is affected.

What it is: CVE-2018-15801 is a low-severity authentication bypass vulnerability in Vmware Spring Framework, published on 19 Dec 2018. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-15801 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.security:spring-security-core (Maven): affected from 5.1.0; fixed in 5.1.2
- org.springframework.security:spring-security-core (Maven): affected from 5.1.0; fixed in 5.1.2
- org.springframework.security:spring-security-oauth2-jose (Maven): affected from 5.1.0; fixed in 5.1.2
- org.springframework.security:spring-security-oauth2-jose (Maven): affected from 5.1.0; fixed in 5.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-15801/ (Markdown: https://insights.sbomify.com/CVE-2018-15801/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-15801
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-15801
- OSV: https://osv.dev/vulnerability/CVE-2018-15801

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-15801/
Summaries are generated and may contain mistakes; the official description above is the record.
