# CVE-2018-16115: Cryptographically Weak Pseudo-Random Number Generator (PRNG) in akka-actor

> Attackers can eavesdrop, replay, or modify Akka Remoting messages if vulnerable custom random number generators are enabled in configuration.

- **Severity:** Critical 9.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Aug 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-mr95-9rr4-668f

## What is CVE-2018-16115?

CVE-2018-16115 is a critical vulnerability in n/a, published on 29 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Lightbend Akka 2.5.x before 2.5.16 allows message disclosure and modification because of an RNG error. A random number generator is used in Akka Remoting for TLS (both classic and Artery Remoting). Akka allows configuration of custom random number generators. For historical reasons, Akka included the AES128CounterSecureRNG and AES256CounterSecureRNG random number generators. The implementations had a bug that caused the generated numbers to be repeated after only a few bytes. The custom RNG implementations were not configured by default but examples in the documentation showed (and therefore implicitly recommended) using the custom ones. This can be used by an attacker to compromise the communication if these random number generators are enabled in configuration. It would be possible to eavesdrop, replay, or modify the messages sent with Akka Remoting/Cluster.

Weakness: CWE-338 (Use of Cryptographically Weak Pseudo-Random Number Generator (PRNG))

## Which versions are affected by CVE-2018-16115?

4 open source packages ship an affected version, including com.typesafe.akka:akka-actor_2.11 and com.typesafe.akka:akka-actor_2.12. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.typesafe.akka:akka-actor_2.11` | Maven | From 2.5.0 | 2.5.16 |
| `com.typesafe.akka:akka-actor_2.11` | Maven | From 2.5.0 | 2.5.16 |
| `com.typesafe.akka:akka-actor_2.12` | Maven | From 2.5.0 | 2.5.16 |
| `com.typesafe.akka:akka-actor_2.12` | Maven | From 2.5.0 | 2.5.16 |

Products: Lightbend Akka.

## How do I fix CVE-2018-16115?

Upgrade com.typesafe.akka:akka-actor_2.11 to 2.5.16 or later.

## Is CVE-2018-16115 being exploited?

There is no known exploitation of CVE-2018-16115 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-16115 and fix it if it is affected.

What it is: CVE-2018-16115 is a critical vulnerability in n/a, published on 29 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-16115 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.typesafe.akka:akka-actor_2.11 (Maven): affected from 2.5.0; fixed in 2.5.16
- com.typesafe.akka:akka-actor_2.11 (Maven): affected from 2.5.0; fixed in 2.5.16
- com.typesafe.akka:akka-actor_2.12 (Maven): affected from 2.5.0; fixed in 2.5.16
- com.typesafe.akka:akka-actor_2.12 (Maven): affected from 2.5.0; fixed in 2.5.16

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-16115/ (Markdown: https://insights.sbomify.com/CVE-2018-16115/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-16115
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-16115
- OSV: https://osv.dev/vulnerability/CVE-2018-16115

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-16115/
Summaries are generated and may contain mistakes; the official description above is the record.
