{"answers":{"affected":"4 open source packages ship an affected version, including com.typesafe.akka:akka-http-core_2.11 and com.typesafe.akka:akka-http-core_2.12. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-16131 in the wild and no public exploit code.","fix":"Upgrade com.typesafe.akka:akka-http-core_2.11 to 10.1.4 or later.","what":"CVE-2018-16131 is a high-severity denial of service vulnerability in n/a, published on 30 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-16131 and fix it if it is affected.\n\nWhat it is: CVE-2018-16131 is a high-severity denial of service vulnerability in n/a, published on 30 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-16131 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.typesafe.akka:akka-http-core_2.11 (Maven): affected from 10.1.0; fixed in 10.1.4\n- com.typesafe.akka:akka-http-core_2.11 (Maven): affected from 10.1.0; fixed in 10.1.4\n- com.typesafe.akka:akka-http-core_2.12 (Maven): affected from 10.1.0; fixed in 10.1.4\n- com.typesafe.akka:akka-http-core_2.12 (Maven): affected from 10.1.0; fixed in 10.1.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-16131/ (Markdown: https://insights.sbomify.com/CVE-2018-16131/index.md)","id":"CVE-2018-16131","markdown":"https://insights.sbomify.com/CVE-2018-16131/index.md","name":"CVE-2018-16131","record":{"aliases":["GHSA-9qgc-p27w-3hjg"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Akka HTTP library","requires_auth":"none","summary":"Remote attackers can cause denial of service via memory consumption and daemon crash using a ZIP bomb in Akka HTTP.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"akka_http","vendor":"lightbend"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"The decodeRequest and decodeRequestWith directives in Lightbend Akka HTTP 10.1.x through 10.1.4 and 10.0.x through 10.0.13 allow remote attackers to cause a denial of service (memory consumption and daemon crash) via a ZIP bomb.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"High severity vulnerability that affects com.typesafe.akka:akka-http-core_2.11 and com.typesafe.akka:akka-http-core_2.12","id":"CVE-2018-16131","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"denial_of_service","year":"2018"},"n_packages":4,"n_references":4,"next":{"headline":"Denial of service in n/a","id":"CVE-2018-16132"},"packages":[{"ecosystem":"Maven","fixed":["10.1.4"],"introduced":["10.1.0"],"last_affected":[],"package":"com.typesafe.akka:akka-http-core_2.11","purl":null,"source":"GHSA-9qgc-p27w-3hjg"},{"ecosystem":"Maven","fixed":["10.1.4"],"introduced":["10.1.0"],"last_affected":[],"package":"com.typesafe.akka:akka-http-core_2.11","purl":"pkg:maven/com.typesafe.akka/akka-http-core_2.11","source":"GHSA-9qgc-p27w-3hjg"},{"ecosystem":"Maven","fixed":["10.1.4"],"introduced":["10.1.0"],"last_affected":[],"package":"com.typesafe.akka:akka-http-core_2.12","purl":null,"source":"GHSA-9qgc-p27w-3hjg"},{"ecosystem":"Maven","fixed":["10.1.4"],"introduced":["10.1.0"],"last_affected":[],"package":"com.typesafe.akka:akka-http-core_2.12","purl":"pkg:maven/com.typesafe.akka/akka-http-core_2.12","source":"GHSA-9qgc-p27w-3hjg"}],"prev":{"headline":"Command injection in n/a","id":"CVE-2018-16130"},"products":["n/a"],"published":"2018-08-30","related":[{"cvss_score":4.7,"headline":"Information disclosure in n/a","id":"CVE-2023-33251","kev_date_added":null,"published":"2023-05-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Remote attackers can cause denial of service via memory consumption and daemon crash using a ZIP bomb in Akka HTTP.","url":"https://insights.sbomify.com/CVE-2018-16131/"}