# CVE-2018-16387: Elefant CMS CSRF Vulnerability

> A CSRF vulnerability in Elefant CMS allows attackers to add new accounts, potentially leading to unauthorized access.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Sep 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-79m2-h67v-35q7

## What is CVE-2018-16387?

CVE-2018-16387 is a high-severity vulnerability in n/a, published on 3 Sep 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An issue was discovered in Elefant CMS before 2.0.5. There is a CSRF vulnerability that can add an account via user/add.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2018-16387?

2 open source packages ship an affected version, including elefant/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `elefant/cms` | Packagist | All versions | 2.0.5 |
| `elefant/cms` | Packagist | All versions | 2.0.5 |

Products: Elefantcms Elefantcms.

## How do I fix CVE-2018-16387?

Upgrade elefant/cms to 2.0.5 or later.

## Is CVE-2018-16387 being exploited?

There is no known exploitation of CVE-2018-16387 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-15601](https://insights.sbomify.com/CVE-2018-15601/): Elefant CMS Improper Input Validation (critical 9.8)
- [CVE-2017-20058](https://insights.sbomify.com/CVE-2017-20058/): Elefant CMS Version Comparison Persistent cross site scriting (medium 4.3)
- [CVE-2012-6521](https://insights.sbomify.com/CVE-2012-6521/): Cross-site scripting in n/a (medium 4.3)
- [CVE-2012-1296](https://insights.sbomify.com/CVE-2012-1296/): Elefant CMS Multiple XSS Vulnerabilities (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-16387 and fix it if it is affected.

What it is: CVE-2018-16387 is a high-severity vulnerability in n/a, published on 3 Sep 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-16387 in the wild and no public exploit code.

Affected packages and fixed versions:
- elefant/cms (Packagist): affected all versions; fixed in 2.0.5
- elefant/cms (Packagist): affected all versions; fixed in 2.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-16387/ (Markdown: https://insights.sbomify.com/CVE-2018-16387/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-16387
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-16387
- OSV: https://osv.dev/vulnerability/CVE-2018-16387

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-16387/
Summaries are generated and may contain mistakes; the official description above is the record.
