{"answers":{"affected":"3 open source packages ship an affected version, including mayan-edms. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-16406 in the wild and no public exploit code.","fix":"Upgrade mayan-edms to 3.0.2 or later.","what":"CVE-2018-16406 is a medium-severity cross-site scripting vulnerability in n/a, published on 3 Sep 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-16406 and fix it if it is affected.\n\nWhat it is: CVE-2018-16406 is a medium-severity cross-site scripting vulnerability in n/a, published on 3 Sep 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-16406 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mayan-edms (PyPI): affected all versions; fixed in 3.0.2\n- mayan-edms (PyPI): affected all versions; fixed in 3.0.2\n- mayan-edms (PyPI): affected all versions; fixed in 3.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-16406/ (Markdown: https://insights.sbomify.com/CVE-2018-16406/index.md)","id":"CVE-2018-16406","markdown":"https://insights.sbomify.com/CVE-2018-16406/index.md","name":"CVE-2018-16406","record":{"aliases":["GHSA-5r76-cjf4-c9qx","PYSEC-2018-14"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Document Management System","requires_auth":"none","summary":"An attacker can inject malicious scripts via crafted cabinet labels in Mayan EDMS, potentially leading to session hijacking or code execution.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"mayan_edms","vendor":"mayan-edms"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"An issue was discovered in Mayan EDMS before 3.0.2. The Cabinets app has XSS via a crafted cabinet label.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Moderate severity vulnerability that affects mayan-edms","id":"CVE-2018-16406","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2018"},"n_packages":3,"n_references":3,"next":{"headline":"Moderate severity vulnerability that affects mayan-edms","id":"CVE-2018-16407"},"packages":[{"ecosystem":"PyPI","fixed":["3.0.2"],"introduced":["0"],"last_affected":[],"package":"mayan-edms","purl":null,"source":"GHSA-5r76-cjf4-c9qx"},{"ecosystem":"PyPI","fixed":["3.0.2"],"introduced":["0"],"last_affected":[],"package":"mayan-edms","purl":"pkg:pypi/mayan-edms","source":"GHSA-5r76-cjf4-c9qx"},{"ecosystem":"PyPI","fixed":["3.0.2"],"introduced":["0"],"last_affected":[],"package":"mayan-edms","purl":"pkg:pypi/mayan-edms","source":"PYSEC-2018-14"}],"prev":{"headline":"mayan-edms Cross-site Scripting vulnerability","id":"CVE-2018-16405"},"products":["n/a"],"published":"2018-09-03","related":[{"cvss_score":6.1,"headline":"mayan-edms Cross-site Scripting vulnerability","id":"CVE-2018-16405","kev_date_added":null,"published":"2018-09-03"},{"cvss_score":6.1,"headline":"Moderate severity vulnerability that affects mayan-edms","id":"CVE-2018-16407","kev_date_added":null,"published":"2018-09-03"},{"cvss_score":5.4,"headline":"Mayan EDMS Tag XSS","id":"CVE-2022-47419","kev_date_added":null,"published":"2023-02-07"},{"cvss_score":5.3,"headline":"Mayan EDMS authentication cross site scripting","id":"CVE-2025-14691","kev_date_added":null,"published":"2025-12-14"},{"cvss_score":5.3,"headline":"Mayan EDMS authentication redirect","id":"CVE-2025-14692","kev_date_added":null,"published":"2025-12-14"},{"cvss_score":3.5,"headline":"Mayan EDMS multiple cross-site scripting (XSS) vulnerabilities","id":"CVE-2014-3840","kev_date_added":null,"published":"2014-05-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"An attacker can inject malicious scripts via crafted cabinet labels in Mayan EDMS, potentially leading to session hijacking or code execution.","url":"https://insights.sbomify.com/CVE-2018-16406/"}