# CVE-2018-16407: Moderate severity vulnerability that affects mayan-edms

> Cross-site scripting vulnerability in Mayan EDMS allows attackers to inject malicious scripts via tag labels, potentially compromising user sessions.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Sep 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-5h6m-9mvx-m6c5, PYSEC-2018-15

## What is CVE-2018-16407?

CVE-2018-16407 is a medium-severity cross-site scripting vulnerability in n/a, published on 3 Sep 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An issue was discovered in Mayan EDMS before 3.0.3. The Tags app has XSS because tag label values are mishandled.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-16407?

3 open source packages ship an affected version, including mayan-edms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mayan-edms` | PyPI | All versions | 3.0.3 |
| `mayan-edms` | PyPI | All versions | 3.0.3 |
| `mayan-edms` | PyPI | All versions | 3.0.3 |

Products: Mayan-Edms Mayan Edms.

## How do I fix CVE-2018-16407?

Upgrade mayan-edms to 3.0.3 or later.

## Is CVE-2018-16407 being exploited?

There is no known exploitation of CVE-2018-16407 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-16405](https://insights.sbomify.com/CVE-2018-16405/): mayan-edms Cross-site Scripting vulnerability (medium 6.1)
- [CVE-2018-16406](https://insights.sbomify.com/CVE-2018-16406/): Moderate severity vulnerability that affects mayan-edms (medium 6.1)
- [CVE-2022-47419](https://insights.sbomify.com/CVE-2022-47419/): Mayan EDMS Tag XSS (medium 5.4)
- [CVE-2025-14691](https://insights.sbomify.com/CVE-2025-14691/): Mayan EDMS authentication cross site scripting (medium 5.3)
- [CVE-2025-14692](https://insights.sbomify.com/CVE-2025-14692/): Mayan EDMS authentication redirect (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-16407 and fix it if it is affected.

What it is: CVE-2018-16407 is a medium-severity cross-site scripting vulnerability in n/a, published on 3 Sep 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-16407 in the wild and no public exploit code.

Affected packages and fixed versions:
- mayan-edms (PyPI): affected all versions; fixed in 3.0.3
- mayan-edms (PyPI): affected all versions; fixed in 3.0.3
- mayan-edms (PyPI): affected all versions; fixed in 3.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-16407/ (Markdown: https://insights.sbomify.com/CVE-2018-16407/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-16407
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-16407
- OSV: https://osv.dev/vulnerability/CVE-2018-16407

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-16407/
Summaries are generated and may contain mistakes; the official description above is the record.
