{"answers":{"affected":"2 open source packages ship an affected version, including ps. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-16460 in the wild and no public exploit code.","fix":"Upgrade ps to 1.0.0 or later.","what":"CVE-2018-16460 is a critical vulnerability in https://github.com/UmbraEngineering ps, published on 7 Sep 2018."},"fix_prompt":"Check this codebase for CVE-2018-16460 and fix it if it is affected.\n\nWhat it is: CVE-2018-16460 is a critical vulnerability in https://github.com/UmbraEngineering ps, published on 7 Sep 2018. \nExploitation: There is no known exploitation of CVE-2018-16460 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ps (npm): affected all versions; fixed in 1.0.0\n- ps (npm): affected all versions; fixed in 1.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-16460/ (Markdown: https://insights.sbomify.com/CVE-2018-16460/index.md)","id":"CVE-2018-16460","markdown":"https://insights.sbomify.com/CVE-2018-16460/index.md","name":"CVE-2018-16460","record":{"aliases":["GHSA-cfhg-9x44-78h2"],"analysis":null,"analysis_generated_by":null,"assigner":"hackerone","cpe":[{"product":"ps","vendor":"umbraengineering"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"},{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"}],"description":"A command Injection in ps package versions \u003c1.0.0 for Node.js allowed arbitrary commands to be executed when attacker controls the PID.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"ps Enables OS Command Injection","id":"CVE-2018-16460","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":null,"year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"Command Injection in libnmap","id":"CVE-2018-16461"},"packages":[{"ecosystem":"npm","fixed":["1.0.0"],"introduced":["0"],"last_affected":[],"package":"ps","purl":null,"source":"GHSA-cfhg-9x44-78h2"},{"ecosystem":"npm","fixed":["1.0.0"],"introduced":["0"],"last_affected":[],"package":"ps","purl":"pkg:npm/ps","source":"GHSA-cfhg-9x44-78h2"}],"prev":{"headline":"Cross-Site Scripting in exceljs","id":"CVE-2018-16459"},"products":["ps"],"published":"2018-09-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["https://github.com/UmbraEngineering"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2018-16460/"}