# CVE-2018-16460: ps Enables OS Command Injection


- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 7 Sep 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-cfhg-9x44-78h2

## What is CVE-2018-16460?

CVE-2018-16460 is a critical vulnerability in https://github.com/UmbraEngineering ps, published on 7 Sep 2018. 

### Official description

A command Injection in ps package versions <1.0.0 for Node.js allowed arbitrary commands to be executed when attacker controls the PID.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2018-16460?

2 open source packages ship an affected version, including ps. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ps` | npm | All versions | 1.0.0 |
| `ps` | npm | All versions | 1.0.0 |

Products: Umbraengineering Ps.

## How do I fix CVE-2018-16460?

Upgrade ps to 1.0.0 or later.

## Is CVE-2018-16460 being exploited?

There is no known exploitation of CVE-2018-16460 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-16460 and fix it if it is affected.

What it is: CVE-2018-16460 is a critical vulnerability in https://github.com/UmbraEngineering ps, published on 7 Sep 2018. 
Exploitation: There is no known exploitation of CVE-2018-16460 in the wild and no public exploit code.

Affected packages and fixed versions:
- ps (npm): affected all versions; fixed in 1.0.0
- ps (npm): affected all versions; fixed in 1.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-16460/ (Markdown: https://insights.sbomify.com/CVE-2018-16460/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-16460
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-16460
- OSV: https://osv.dev/vulnerability/CVE-2018-16460

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-16460/
Summaries are generated and may contain mistakes; the official description above is the record.
