{"answers":{"affected":"2 open source packages ship an affected version, including libnmap. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-16461 in the wild and no public exploit code.","fix":"Upgrade libnmap to 0.4.16 or later.","what":"CVE-2018-16461 is a critical vulnerability in libnmap, published on 30 Oct 2018."},"fix_prompt":"Check this codebase for CVE-2018-16461 and fix it if it is affected.\n\nWhat it is: CVE-2018-16461 is a critical vulnerability in libnmap, published on 30 Oct 2018. \nExploitation: There is no known exploitation of CVE-2018-16461 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- libnmap (npm): affected all versions; fixed in 0.4.16\n- libnmap (npm): affected all versions; fixed in 0.4.16\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-16461/ (Markdown: https://insights.sbomify.com/CVE-2018-16461/index.md)","id":"CVE-2018-16461","markdown":"https://insights.sbomify.com/CVE-2018-16461/index.md","name":"CVE-2018-16461","record":{"aliases":["GHSA-7g2w-6r25-2j7p"],"analysis":null,"analysis_generated_by":null,"assigner":"hackerone","cpe":[{"product":"libnmap","vendor":"libnmap_project"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"},{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"}],"description":"A command injection vulnerability in libnmapp package for versions \u003c0.4.16 allows arbitrary commands to be executed via arguments to the range options.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Command Injection in libnmap","id":"CVE-2018-16461","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":null,"year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"Command Injection in apex-publish-static-files","id":"CVE-2018-16462"},"packages":[{"ecosystem":"npm","fixed":["0.4.16"],"introduced":["0"],"last_affected":[],"package":"libnmap","purl":null,"source":"GHSA-7g2w-6r25-2j7p"},{"ecosystem":"npm","fixed":["0.4.16"],"introduced":["0"],"last_affected":[],"package":"libnmap","purl":"pkg:npm/libnmap","source":"GHSA-7g2w-6r25-2j7p"}],"prev":{"headline":"ps Enables OS Command Injection","id":"CVE-2018-16460"},"products":["libnmap"],"published":"2018-10-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2018-16461/"}