# CVE-2018-16468: Loofah Cross-site Scripting vulnerability

> Attackers can inject malicious JavaScript into sanitized output via crafted SVG elements, leading to XSS in applications using the Loofah gem.

- **Severity:** Medium 5.4 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Oct 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-16468, DSA-4364-1, GHSA-g4xq-jx4w-4cjv, SUSE-SU-2018:3928-1, UBUNTU-CVE-2018-16468

## What is CVE-2018-16468?

CVE-2018-16468 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 30 Oct 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

In the Loofah gem for Ruby, through v2.2.2, unsanitized JavaScript may occur in sanitized output when a crafted SVG element is republished.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-16468?

2 open source packages ship an affected version, including loofah. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `loofah` | RubyGems | All versions | 2.2.3 |
| `loofah` | RubyGems | All versions | 2.2.3 |
| `rubygem-loofah` | SUSE:Linux Enterprise High Availability Extension 15 | All versions | 2.2.2-4.3.1 |

Products: Debian Debian Linux, Loofah Project Loofah.

## How do I fix CVE-2018-16468?

Upgrade loofah to 2.2.3 or later.

## Is CVE-2018-16468 being exploited?

There is no known exploitation of CVE-2018-16468 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-16468 and fix it if it is affected.

What it is: CVE-2018-16468 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 30 Oct 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-16468 in the wild and no public exploit code.

Affected packages and fixed versions:
- loofah (RubyGems): affected all versions; fixed in 2.2.3
- loofah (RubyGems): affected all versions; fixed in 2.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-16468/ (Markdown: https://insights.sbomify.com/CVE-2018-16468/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-16468
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-16468
- OSV: https://osv.dev/vulnerability/CVE-2018-16468

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-16468/
Summaries are generated and may contain mistakes; the official description above is the record.
