# CVE-2018-16469: Prototype Pollution in merge

> Attackers can cause denial of service by modifying Object prototype properties via the merge.recursive function in the merge library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Oct 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-f9cm-qmx5-m98h, ROOT-APP-NPM-CVE-2018-16469, UBUNTU-CVE-2018-16469

## What is CVE-2018-16469?

CVE-2018-16469 is a high-severity denial of service vulnerability in HackerOne merge, published on 30 Oct 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The merge.recursive function in the merge package <1.2.1 can be tricked into adding or modifying properties of the Object prototype. These properties will be present on all objects allowing for a denial of service attack.

Weakness: CWE-20 (Improper Input Validation), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2018-16469?

2 open source packages ship an affected version, including merge. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `merge` | npm | All versions | 1.2.1 |
| `merge` | npm | All versions | 1.2.1 |

Products: Merge Project Merge.

## How do I fix CVE-2018-16469?

Upgrade merge to 1.2.1 or later.

## Is CVE-2018-16469 being exploited?

There is no known exploitation of CVE-2018-16469 in the wild and no public exploit code.

## Other vulnerabilities in HackerOne merge

- [CVE-2020-28499](https://insights.sbomify.com/CVE-2020-28499/): Prototype Pollution (high 7.3)
- [CVE-2021-3645](https://insights.sbomify.com/CVE-2021-3645/): Prototype Pollution in viking04/merge (medium 6.8)
- [CVE-2021-23397](https://insights.sbomify.com/CVE-2021-23397/): Prototype Pollution (medium 5.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-16469 and fix it if it is affected.

What it is: CVE-2018-16469 is a high-severity denial of service vulnerability in HackerOne merge, published on 30 Oct 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-16469 in the wild and no public exploit code.

Affected packages and fixed versions:
- merge (npm): affected all versions; fixed in 1.2.1
- merge (npm): affected all versions; fixed in 1.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-16469/ (Markdown: https://insights.sbomify.com/CVE-2018-16469/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-16469
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-16469
- OSV: https://osv.dev/vulnerability/CVE-2018-16469

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-16469/
Summaries are generated and may contain mistakes; the official description above is the record.
