# CVE-2018-16470: Rack vulnerable to Denial of Service

> Attackers can cause excessive CPU consumption via crafted requests, leading to denial of service in applications using the Rack multipart parser.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Nov 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-hg78-4f6x-99wq

## What is CVE-2018-16470?

CVE-2018-16470 is a high-severity denial of service vulnerability in Rack, published on 13 Nov 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

There is a possible DoS vulnerability in the multipart parser in Rack before 2.0.6. Specially crafted requests can cause the multipart parser to enter a pathological state, causing the parser to use CPU resources disproportionate to the request size.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2018-16470?

2 open source packages ship an affected version, including rack. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rack` | RubyGems | From 2.0.4 | 2.0.6 |
| `rack` | RubyGems | From 2.0.4 | 2.0.6 |

Products: Rack Project Rack.

## How do I fix CVE-2018-16470?

Upgrade rack to 2.0.6 or later.

## Is CVE-2018-16470 being exploited?

There is no known exploitation of CVE-2018-16470 in the wild and no public exploit code.

## Other vulnerabilities in Rack

- [CVE-2013-0263](https://insights.sbomify.com/CVE-2013-0263/): Rack arbitrary code execution via timing attack (medium 5.1)
- [CVE-2013-0183](https://insights.sbomify.com/CVE-2013-0183/): Rack rubygems receiving excessively long lines triggers out-of-memory error (medium 5.0)
- [CVE-2011-5036](https://insights.sbomify.com/CVE-2011-5036/): Rack Gem Subject to Denial of Service via Hash Collisions (medium 5.0)
- [CVE-2012-6109](https://insights.sbomify.com/CVE-2012-6109/): Rack vulnerable to REDoS (medium 4.3)
- [CVE-2013-0184](https://insights.sbomify.com/CVE-2013-0184/): Rack vulnerable to Denial of Service (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-16470 and fix it if it is affected.

What it is: CVE-2018-16470 is a high-severity denial of service vulnerability in Rack, published on 13 Nov 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-16470 in the wild and no public exploit code.

Affected packages and fixed versions:
- rack (RubyGems): affected from 2.0.4; fixed in 2.0.6
- rack (RubyGems): affected from 2.0.4; fixed in 2.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-16470/ (Markdown: https://insights.sbomify.com/CVE-2018-16470/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-16470
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-16470
- OSV: https://osv.dev/vulnerability/CVE-2018-16470

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-16470/
Summaries are generated and may contain mistakes; the official description above is the record.
