# CVE-2018-16472: Prototype Pollution in cached-path-relative

> Prototype pollution in cached-path-relative allows attackers to inject properties into Object.prototype, causing a denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Nov 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-16472, GHSA-hc9w-4p87-j549, UBUNTU-CVE-2018-16472

## What is CVE-2018-16472?

CVE-2018-16472 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 6 Nov 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A prototype pollution attack in cached-path-relative versions <=1.0.1 allows an attacker to inject properties on Object.prototype which are then inherited by all the JS objects through the prototype chain causing a DoS attack.

Weakness: CWE-20 (Improper Input Validation), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2018-16472?

2 open source packages ship an affected version, including cached-path-relative. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cached-path-relative` | npm | All versions | 1.0.2 |
| `cached-path-relative` | npm | All versions | 1.0.2 |

Products: Cached-Path-Relative Project Cached-Path-Relative, Debian Debian Linux.

## How do I fix CVE-2018-16472?

Upgrade cached-path-relative to 1.0.2 or later.

## Is CVE-2018-16472 being exploited?

There is no known exploitation of CVE-2018-16472 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2021-23518](https://insights.sbomify.com/CVE-2021-23518/): Prototype Pollution (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-16472 and fix it if it is affected.

What it is: CVE-2018-16472 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 6 Nov 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-16472 in the wild and no public exploit code.

Affected packages and fixed versions:
- cached-path-relative (npm): affected all versions; fixed in 1.0.2
- cached-path-relative (npm): affected all versions; fixed in 1.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-16472/ (Markdown: https://insights.sbomify.com/CVE-2018-16472/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-16472
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-16472
- OSV: https://osv.dev/vulnerability/CVE-2018-16472

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-16472/
Summaries are generated and may contain mistakes; the official description above is the record.
