CVE-2018-16483 Authentication Bypass by Spoofing in express-cart

High 8.8 Published Updated

Unprivileged users can escalate privileges to administrator by adding new admin accounts due to flawed access control in the express-cart library.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2018-16483?

CVE-2018-16483 is a high-severity vulnerability in HackerOne express-cart, published on 1 Feb 2019. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A deficiency in the access control in module express-cart <=1.1.5 allows unprivileged users to add new users to the application as administrators.

Weakness: CWE-290

Which versions are affected by CVE-2018-16483?

2 open source packages ship an affected version, including express-cart. It affects 1 product.

PackageAffectedFixed in
express-cart npmAll versions1.1.6
express-cart npmAll versions1.1.6

Products include Express-Cart Project Express-Cart.

How do I fix CVE-2018-16483?

Upgrade express-cart to 1.1.6 or later.

Is CVE-2018-16483 being exploited?

There is no known exploitation of CVE-2018-16483 in the wild and no public exploit code.

Sources

Also known as GHSA-wj36-v8j4-pc7c.

Is CVE-2018-16483 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free