{"answers":{"affected":"2 open source packages ship an affected version, including express-cart. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-16483 in the wild and no public exploit code.","fix":"Upgrade express-cart to 1.1.6 or later.","what":"CVE-2018-16483 is a high-severity vulnerability in HackerOne express-cart, published on 1 Feb 2019. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-16483 and fix it if it is affected.\n\nWhat it is: CVE-2018-16483 is a high-severity vulnerability in HackerOne express-cart, published on 1 Feb 2019. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-16483 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- express-cart (npm): affected all versions; fixed in 1.1.6\n- express-cart (npm): affected all versions; fixed in 1.1.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-16483/ (Markdown: https://insights.sbomify.com/CVE-2018-16483/index.md)","id":"CVE-2018-16483","markdown":"https://insights.sbomify.com/CVE-2018-16483/index.md","name":"CVE-2018-16483","record":{"aliases":["GHSA-wj36-v8j4-pc7c"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Express.js cart library","requires_auth":"low_privilege","summary":"Unprivileged users can escalate privileges to administrator by adding new admin accounts due to flawed access control in the express-cart library.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"express-cart","vendor":"express-cart_project"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-290","name":"Authentication Bypass by Spoofing"}],"description":"A deficiency in the access control in module express-cart \u003c=1.1.5 allows unprivileged users to add new users to the application as administrators.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Authentication Bypass by Spoofing in express-cart","id":"CVE-2018-16483","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"privilege_escalation","year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"Cross-Site Scripting in m-server","id":"CVE-2018-16484"},"packages":[{"ecosystem":"npm","fixed":["1.1.6"],"introduced":["0"],"last_affected":[],"package":"express-cart","purl":null,"source":"GHSA-wj36-v8j4-pc7c"},{"ecosystem":"npm","fixed":["1.1.6"],"introduced":["0"],"last_affected":[],"package":"express-cart","purl":"pkg:npm/express-cart","source":"GHSA-wj36-v8j4-pc7c"}],"prev":{"headline":"mcstatic directory traversal vulnerability","id":"CVE-2018-16482"},"products":["express-cart"],"published":"2019-02-01","related":[{"cvss_score":8.8,"headline":"Cross-Site Request Forgery in express-cart","id":"CVE-2020-22403","kev_date_added":null,"published":"2021-08-12"},{"cvss_score":8.8,"headline":"express-cart unrestricted file upload vulnerability","id":"CVE-2018-3758","kev_date_added":null,"published":"2018-06-07"},{"cvss_score":4.8,"headline":"Cross-site Scripting in express-cart","id":"CVE-2021-32573","kev_date_added":null,"published":"2021-05-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["HackerOne"]},"summary":"Unprivileged users can escalate privileges to administrator by adding new admin accounts due to flawed access control in the express-cart library.","url":"https://insights.sbomify.com/CVE-2018-16483/"}