# CVE-2018-16483: Authentication Bypass by Spoofing in express-cart

> Unprivileged users can escalate privileges to administrator by adding new admin accounts due to flawed access control in the express-cart library.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Feb 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-wj36-v8j4-pc7c

## What is CVE-2018-16483?

CVE-2018-16483 is a high-severity vulnerability in HackerOne express-cart, published on 1 Feb 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A deficiency in the access control in module express-cart <=1.1.5 allows unprivileged users to add new users to the application as administrators.

Weakness: CWE-290 (Authentication Bypass by Spoofing)

## Which versions are affected by CVE-2018-16483?

2 open source packages ship an affected version, including express-cart. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `express-cart` | npm | All versions | 1.1.6 |
| `express-cart` | npm | All versions | 1.1.6 |

Products: Express-Cart Project Express-Cart.

## How do I fix CVE-2018-16483?

Upgrade express-cart to 1.1.6 or later.

## Is CVE-2018-16483 being exploited?

There is no known exploitation of CVE-2018-16483 in the wild and no public exploit code.

## Other vulnerabilities in HackerOne express-cart

- [CVE-2020-22403](https://insights.sbomify.com/CVE-2020-22403/): Cross-Site Request Forgery in express-cart (high 8.8)
- [CVE-2018-3758](https://insights.sbomify.com/CVE-2018-3758/): express-cart unrestricted file upload vulnerability (high 8.8)
- [CVE-2021-32573](https://insights.sbomify.com/CVE-2021-32573/): Cross-site Scripting in express-cart (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-16483 and fix it if it is affected.

What it is: CVE-2018-16483 is a high-severity vulnerability in HackerOne express-cart, published on 1 Feb 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-16483 in the wild and no public exploit code.

Affected packages and fixed versions:
- express-cart (npm): affected all versions; fixed in 1.1.6
- express-cart (npm): affected all versions; fixed in 1.1.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-16483/ (Markdown: https://insights.sbomify.com/CVE-2018-16483/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-16483
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-16483
- OSV: https://osv.dev/vulnerability/CVE-2018-16483

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-16483/
Summaries are generated and may contain mistakes; the official description above is the record.
