# CVE-2018-16484: Cross-Site Scripting in m-server

> An attacker can execute malicious JavaScript or HTML via unescaped folder names in the m-server module, potentially compromising user sessions.

- **Severity:** Medium 5.4 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Feb 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-gmxv-xf2q-6j8m

## What is CVE-2018-16484?

CVE-2018-16484 is a medium-severity cross-site scripting vulnerability in HackerOne m-server, published on 1 Feb 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A XSS vulnerability was found in module m-server <1.4.2 that allows malicious Javascript code or HTML to be executed, due to the lack of escaping for special characters in folder names.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-16484?

2 open source packages ship an affected version, including m-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `m-server` | npm | All versions | 1.4.2 |
| `m-server` | npm | All versions | 1.4.2 |

Products: M-Server Project M-Server.

## How do I fix CVE-2018-16484?

Upgrade m-server to 1.4.2 or later.

## Is CVE-2018-16484 being exploited?

There is no known exploitation of CVE-2018-16484 in the wild and no public exploit code.

## Other vulnerabilities in HackerOne m-server

- [CVE-2018-16485](https://insights.sbomify.com/CVE-2018-16485/): m-server Vulnerable to Directory Traversal (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-16484 and fix it if it is affected.

What it is: CVE-2018-16484 is a medium-severity cross-site scripting vulnerability in HackerOne m-server, published on 1 Feb 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-16484 in the wild and no public exploit code.

Affected packages and fixed versions:
- m-server (npm): affected all versions; fixed in 1.4.2
- m-server (npm): affected all versions; fixed in 1.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-16484/ (Markdown: https://insights.sbomify.com/CVE-2018-16484/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-16484
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-16484
- OSV: https://osv.dev/vulnerability/CVE-2018-16484

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-16484/
Summaries are generated and may contain mistakes; the official description above is the record.
