{"answers":{"affected":"2 open source packages ship an affected version, including m-server. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-16485 in the wild and no public exploit code.","fix":"Upgrade m-server to 1.4.1 or later.","what":"CVE-2018-16485 is a medium-severity path traversal vulnerability in HackerOne m-server, published on 1 Feb 2019. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-16485 and fix it if it is affected.\n\nWhat it is: CVE-2018-16485 is a medium-severity path traversal vulnerability in HackerOne m-server, published on 1 Feb 2019. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-16485 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- m-server (npm): affected all versions; fixed in 1.4.1\n- m-server (npm): affected all versions; fixed in 1.4.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-16485/ (Markdown: https://insights.sbomify.com/CVE-2018-16485/index.md)","id":"CVE-2018-16485","markdown":"https://insights.sbomify.com/CVE-2018-16485/index.md","name":"CVE-2018-16485","record":{"aliases":["GHSA-899g-6q6w-7v94"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js server module","requires_auth":"low_privilege","summary":"A path traversal flaw in the m-server module allows attackers to read arbitrary files on the server by manipulating URL requests.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"m-server","vendor":"m-server_project"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Path Traversal vulnerability in module m-server \u003c1.4.1 allows malicious user to access unauthorized content of any file in the directory tree e.g. /etc/passwd by appending slashes to the URL request.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"m-server Vulnerable to Directory Traversal","id":"CVE-2018-16485","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"path_traversal","year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"Prototype Pollution in defaults-deep","id":"CVE-2018-16486"},"packages":[{"ecosystem":"npm","fixed":["1.4.1"],"introduced":["0"],"last_affected":[],"package":"m-server","purl":null,"source":"GHSA-899g-6q6w-7v94"},{"ecosystem":"npm","fixed":["1.4.1"],"introduced":["0"],"last_affected":[],"package":"m-server","purl":"pkg:npm/m-server","source":"GHSA-899g-6q6w-7v94"}],"prev":{"headline":"Cross-Site Scripting in m-server","id":"CVE-2018-16484"},"products":["m-server"],"published":"2019-02-01","related":[{"cvss_score":5.4,"headline":"Cross-Site Scripting in m-server","id":"CVE-2018-16484","kev_date_added":null,"published":"2019-02-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["HackerOne"]},"summary":"A path traversal flaw in the m-server module allows attackers to read arbitrary files on the server by manipulating URL requests.","url":"https://insights.sbomify.com/CVE-2018-16485/"}