# CVE-2018-16487: Prototype Pollution in lodash

> Prototype pollution in lodash allows attackers to modify Object.prototype, potentially leading to code execution or privilege escalation in applications using the library.

- **Severity:** Medium 5.6 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Feb 2019
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-16487, GHSA-4xc9-xhrj-v574, MINI-86gc-qrf2-3cc4, MINI-c2v2-m3rm-4xqq, ROOT-APP-NPM-CVE-2018-16487, UBUNTU-CVE-2018-16487

## What is CVE-2018-16487?

CVE-2018-16487 is a medium-severity vulnerability in HackerOne lodash, published on 1 Feb 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A prototype pollution vulnerability was found in lodash <4.17.11 where the functions merge, mergeWith, and defaultsDeep can be tricked into adding or modifying properties of Object.prototype.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2018-16487?

4 open source packages ship an affected version, including lodash-rails and lodash. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lodash-rails` | RubyGems | All versions | 4.17.11 |
| `lodash-rails` | RubyGems | All versions | 4.17.11 |
| `lodash` | npm | All versions | 4.17.11 |
| `lodash` | npm | All versions | 4.17.11 |

Products: Lodash Lodash.

## How do I fix CVE-2018-16487?

Upgrade lodash-rails to 4.17.11 or later.

## Is CVE-2018-16487 being exploited?

There is no known exploitation of CVE-2018-16487 in the wild and no public exploit code.

## Other vulnerabilities in HackerOne lodash

- [CVE-2026-4800](https://insights.sbomify.com/CVE-2026-4800/): lodash vulnerable to Code Injection via `_.template` imports key names (high 8.1)
- [CVE-2020-8203](https://insights.sbomify.com/CVE-2020-8203/): Prototype Pollution in lodash (high 7.4)
- [CVE-2021-23337](https://insights.sbomify.com/CVE-2021-23337/): Command Injection (high 7.2)
- [CVE-2025-13465](https://insights.sbomify.com/CVE-2025-13465/): Prototype Pollution Vulnerability in Lodash _.unset and _.omit functions (medium 6.9)
- [CVE-2026-2950](https://insights.sbomify.com/CVE-2026-2950/): lodash vulnerable to Prototype Pollution via array path bypass in `_.unset` and `_.omit` (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-16487 and fix it if it is affected.

What it is: CVE-2018-16487 is a medium-severity vulnerability in HackerOne lodash, published on 1 Feb 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-16487 in the wild and no public exploit code.

Affected packages and fixed versions:
- lodash-rails (RubyGems): affected all versions; fixed in 4.17.11
- lodash-rails (RubyGems): affected all versions; fixed in 4.17.11
- lodash (npm): affected all versions; fixed in 4.17.11
- lodash (npm): affected all versions; fixed in 4.17.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-16487/ (Markdown: https://insights.sbomify.com/CVE-2018-16487/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-16487
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-16487
- OSV: https://osv.dev/vulnerability/CVE-2018-16487

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-16487/
Summaries are generated and may contain mistakes; the official description above is the record.
