# CVE-2018-16489: Prototype Pollution in just-extend

> Prototype pollution in just-extend allows attackers to inject properties into Object.prototype, potentially leading to code execution or denial of service.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Feb 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-675m-85rw-j3w4

## What is CVE-2018-16489?

CVE-2018-16489 is a critical code injection vulnerability in HackerOne just-extend, published on 1 Feb 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A prototype pollution vulnerability was found in just-extend <4.0.0 that allows attack to inject properties onto Object.prototype through its functions.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2018-16489?

2 open source packages ship an affected version, including just-extend. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `just-extend` | npm | All versions | 4.0.0 |
| `just-extend` | npm | All versions | 4.0.0 |

Products: Just-Extend Project Just-Extend.

## How do I fix CVE-2018-16489?

Upgrade just-extend to 4.0.0 or later.

## Is CVE-2018-16489 being exploited?

There is no known exploitation of CVE-2018-16489 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-16489 and fix it if it is affected.

What it is: CVE-2018-16489 is a critical code injection vulnerability in HackerOne just-extend, published on 1 Feb 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-16489 in the wild and no public exploit code.

Affected packages and fixed versions:
- just-extend (npm): affected all versions; fixed in 4.0.0
- just-extend (npm): affected all versions; fixed in 4.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-16489/ (Markdown: https://insights.sbomify.com/CVE-2018-16489/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-16489
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-16489
- OSV: https://osv.dev/vulnerability/CVE-2018-16489

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-16489/
Summaries are generated and may contain mistakes; the official description above is the record.
