# CVE-2018-16492: Prototype Pollution in extend

> Attackers can inject arbitrary properties into Object.prototype via prototype pollution in the extend library, potentially leading to code execution or privilege escalation.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Feb 2019
- **Updated:** 5 Aug 2024
- **Also known as:** CLSA-2026-1773188141, DEBIAN-CVE-2018-16492, GHSA-qrmc-fj45-qfc2, UBUNTU-CVE-2018-16492

## What is CVE-2018-16492?

CVE-2018-16492 is a critical code injection vulnerability in HackerOne extend, published on 1 Feb 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A prototype pollution vulnerability was found in module extend <2.0.2, ~<3.0.2 that allows an attacker to inject arbitrary properties onto Object.prototype.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2018-16492?

4 open source packages ship an affected version, including extend. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `extend` | npm | From 1.1.3 | 2.0.2 |
| `extend` | npm | From 1.1.3 | 2.0.2 |
| `extend` | npm | From 3.0.0 | 3.0.2 |
| `extend` | npm | From 3.0.0 | 3.0.2 |

Products: Extend Project Extend.

## How do I fix CVE-2018-16492?

Upgrade extend to a fixed version for your release line: 2.0.2 or 3.0.2.

## Is CVE-2018-16492 being exploited?

There is no known exploitation of CVE-2018-16492 in the wild and no public exploit code.

Public exploit code:

- https://github.com/dsp-testing/CVE-2018-16492 (github_poc): https://github.com/dsp-testing/CVE-2018-16492

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-16492 and fix it if it is affected.

What it is: CVE-2018-16492 is a critical code injection vulnerability in HackerOne extend, published on 1 Feb 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-16492 in the wild and no public exploit code.

Affected packages and fixed versions:
- extend (npm): affected from 1.1.3; fixed in 2.0.2
- extend (npm): affected from 1.1.3; fixed in 2.0.2
- extend (npm): affected from 3.0.0; fixed in 3.0.2
- extend (npm): affected from 3.0.0; fixed in 3.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-16492/ (Markdown: https://insights.sbomify.com/CVE-2018-16492/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-16492
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-16492
- OSV: https://osv.dev/vulnerability/CVE-2018-16492

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-16492/
Summaries are generated and may contain mistakes; the official description above is the record.
