# CVE-2018-16514: MantisBT cross-site scripting (XSS) vulnerability through crafted PATH_INFO

> Remote attackers can inject arbitrary code via crafted PATH_INFO in MantisBT filter pages, potentially executing scripts if CSP permits.

- **Severity:** Medium 4.7 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Jun 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-3qv7-98vm-xx2v

## What is CVE-2018-16514?

CVE-2018-16514 is a medium-severity cross-site scripting vulnerability in Mantisbt Mantisbt, published on 20 Jun 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A cross-site scripting (XSS) vulnerability in the View Filters page (view_filters_page.php) and Edit Filter page (manage_filter_edit_page.php) in MantisBT 2.1.0 through 2.17.0 allows remote attackers to inject arbitrary code (if CSP settings permit it) through a crafted PATH_INFO. NOTE: this vulnerability exists because of an incomplete fix for CVE-2018-13055.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-16514?

2 open source packages ship an affected version, including mantisbt/mantisbt. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mantisbt/mantisbt` | Packagist | From 2.1.0 | 2.17.1 |
| `mantisbt/mantisbt` | Packagist | From 2.1.0 | 2.17.1 |

Products: Mantisbt Mantisbt.

## How do I fix CVE-2018-16514?

Upgrade mantisbt/mantisbt to 2.17.1 or later.

## Is CVE-2018-16514 being exploited?

There is no known exploitation of CVE-2018-16514 in the wild and no public exploit code.

## Other vulnerabilities in Mantisbt Mantisbt

- [CVE-2019-15074](https://insights.sbomify.com/CVE-2019-15074/): MantisBT allows cross-site scripting (XSS) via crafted filename (critical 9.6)
- [CVE-2026-30849](https://insights.sbomify.com/CVE-2026-30849/): MantisBT SOAP API has an authentication bypass vulnerability on MySQL (critical 9.3)
- [CVE-2025-47776](https://insights.sbomify.com/CVE-2025-47776/): MantisBT: Authentication bypass for some passwords due to PHP type juggling (high 8.8)
- [CVE-2017-7615](https://insights.sbomify.com/CVE-2017-7615/): MantisBT allows arbitrary password reset (high 8.8)
- [CVE-2026-33517](https://insights.sbomify.com/CVE-2026-33517/): MantisBT Vulnerable to Stored HTML Injection in Tag Delete Confirmation (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-16514 and fix it if it is affected.

What it is: CVE-2018-16514 is a medium-severity cross-site scripting vulnerability in Mantisbt Mantisbt, published on 20 Jun 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-16514 in the wild and no public exploit code.

Affected packages and fixed versions:
- mantisbt/mantisbt (Packagist): affected from 2.1.0; fixed in 2.17.1
- mantisbt/mantisbt (Packagist): affected from 2.1.0; fixed in 2.17.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-16514/ (Markdown: https://insights.sbomify.com/CVE-2018-16514/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-16514
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-16514
- OSV: https://osv.dev/vulnerability/CVE-2018-16514

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-16514/
Summaries are generated and may contain mistakes; the official description above is the record.
