CVE-2018-16515 Matrix Synapse Improper Signature Validation
Remote attackers can spoof events due to improper signature validation, compromising data integrity in Matrix Synapse deployments.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2018-16515?
CVE-2018-16515 is a high-severity vulnerability in Debian Debian Linux, published on 18 Sep 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Matrix Synapse before 0.33.3.1 allows remote attackers to spoof events and possibly have unspecified other impacts by leveraging improper transaction and event signature validation.
Weakness: CWE-347
Which versions are affected by CVE-2018-16515?
5 open source packages ship an affected version, including matrix-synapse. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
matrix-synapse PyPI | All versions | 0.33.2.1, 0.33.3.1 |
matrix-synapse PyPI | All versions | 0.33.2.1 |
matrix-synapse PyPI | All versions | 0.33.2.1 |
matrix-synapse PyPI | From 0.33.3 | 0.33.3.1 |
matrix-synapse PyPI | From 0.33.3 | 0.33.3.1 |
Products include Debian Debian Linux, Matrix Synapse.
How do I fix CVE-2018-16515?
Upgrade matrix-synapse to a fixed version for your release line: 0.33.2.1 or 0.33.3.1.
Is CVE-2018-16515 being exploited?
There is no known exploitation of CVE-2018-16515 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as GHSA-fmvh-rvq5-hhjx, PYSEC-2026-845, UBUNTU-CVE-2018-16515.