# CVE-2018-16516: Flask-Admin Cross-site Scripting vulnerability

> Reflected XSS in Flask-Admin allows attackers to execute arbitrary scripts in victim browsers via crafted URLs.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Sep 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-894g-6j7q-2hx6, PYSEC-2018-54

## What is CVE-2018-16516?

CVE-2018-16516 is a medium-severity cross-site scripting vulnerability in n/a, published on 5 Sep 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

helpers.py in Flask-Admin 1.5.2 has Reflected XSS via a crafted URL.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-16516?

3 open source packages ship an affected version, including flask-admin and Flask-Admin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flask-admin` | PyPI | All versions | 1.5.3 |
| `flask-admin` | PyPI | All versions | 1.5.3 |
| `Flask-Admin` | PyPI | All versions | 1.5.3 |

Products: Flask-Admin Project Flask-Admin.

## How do I fix CVE-2018-16516?

Upgrade flask-admin to 1.5.3 or later.

## Is CVE-2018-16516 being exploited?

There is no known exploitation of CVE-2018-16516 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-16516 and fix it if it is affected.

What it is: CVE-2018-16516 is a medium-severity cross-site scripting vulnerability in n/a, published on 5 Sep 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-16516 in the wild and no public exploit code.

Affected packages and fixed versions:
- flask-admin (PyPI): affected all versions; fixed in 1.5.3
- flask-admin (PyPI): affected all versions; fixed in 1.5.3
- Flask-Admin (PyPI): affected all versions; fixed in 1.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-16516/ (Markdown: https://insights.sbomify.com/CVE-2018-16516/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-16516
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-16516
- OSV: https://osv.dev/vulnerability/CVE-2018-16516

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-16516/
Summaries are generated and may contain mistakes; the official description above is the record.
