CVE-2018-16650 phpMyFAQ CSRF
High 8.8
Published
Updated
Check this codebase for CVE-2018-16650 and fix it if it is affected.
What it is: CVE-2018-16650 is a high-severity vulnerability in Phpmyfaq Phpmyfaq, published on 7 Sep 2018.
Exploitation: There is no known exploitation of CVE-2018-16650 in the wild and no public exploit code.
Affected packages and fixed versions:
- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 2.9.11
- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 2.9.11
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/CVE-2018-16650/ (Markdown: https://insights.sbomify.com/CVE-2018-16650/index.md)
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2018-16650?
CVE-2018-16650 is a high-severity vulnerability in Phpmyfaq Phpmyfaq, published on 7 Sep 2018.
Official description
phpMyFAQ before 2.9.11 allows CSRF.
Weakness: CWE-352
Which versions are affected by CVE-2018-16650?
2 open source packages ship an affected version, including thorsten/phpmyfaq. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
thorsten/phpmyfaq Packagist | All versions | 2.9.11 |
thorsten/phpmyfaq Packagist | All versions | 2.9.11 |
Products include Phpmyfaq Phpmyfaq.
How do I fix CVE-2018-16650?
Upgrade thorsten/phpmyfaq to 2.9.11 or later.
Is CVE-2018-16650 being exploited?
There is no known exploitation of CVE-2018-16650 in the wild and no public exploit code.
Other vulnerabilities in Phpmyfaq Phpmyfaq
- CVE-2023-0310 Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq
- CVE-2022-4407 Cross-site Scripting (XSS) - Reflected in thorsten/phpmyfaq
- CVE-2017-11187 Security feature bypass in n/a
- CVE-2026-76213 phpMyFAQ before 4.1.7 2FA Brute-Force via Session-Scoped Throttle
- CVE-2026-76214 phpMyFAQ before 4.1.7 WebAuthn Replay Attack via Challenge
Sources
Also known as GHSA-p57w-9q28-j6v7.