# CVE-2018-16733: Go Ethereum Improper Input Validation

> An attacker can cause a denial of service in Go Ethereum by providing invalid block ranges to the trace API due to missing validation.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Sep 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-qr2j-wrhx-4829, GO-2022-0871

## What is CVE-2018-16733?

CVE-2018-16733 is a high-severity vulnerability in n/a, published on 8 Sep 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Go Ethereum (aka geth) before 1.8.14, TraceChain in eth/api_tracer.go does not verify that the end block is after the start block.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2018-16733?

3 open source packages ship an affected version, including github.com/ethereum/go-ethereum. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/ethereum/go-ethereum` | Go | All versions | 1.8.14 |
| `github.com/ethereum/go-ethereum` | Go | All versions | 1.8.14 |
| `github.com/ethereum/go-ethereum` | Go | All versions | 1.8.14 |

Products: Ethereum Go Ethereum.

## How do I fix CVE-2018-16733?

Upgrade github.com/ethereum/go-ethereum to 1.8.14 or later.

## Is CVE-2018-16733 being exploited?

There is no known exploitation of CVE-2018-16733 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-26314](https://insights.sbomify.com/CVE-2026-26314/): Go Ethereum affected by DoS via malicious p2p message (high 8.7)
- [CVE-2023-42319](https://insights.sbomify.com/CVE-2023-42319/): go-ethereum vulnerable to denial of service via crafted GraphQL query (high 7.5)
- [CVE-2023-40591](https://insights.sbomify.com/CVE-2023-40591/): Denial of service via malicious p2p message in go-ethereum (high 7.5)
- [CVE-2021-42219](https://insights.sbomify.com/CVE-2021-42219/): Denial of service in go-ethereum (high 7.5)
- [CVE-2022-23327](https://insights.sbomify.com/CVE-2022-23327/): Denial of Service in Go-Ethereum (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-16733 and fix it if it is affected.

What it is: CVE-2018-16733 is a high-severity vulnerability in n/a, published on 8 Sep 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-16733 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/ethereum/go-ethereum (Go): affected all versions; fixed in 1.8.14
- github.com/ethereum/go-ethereum (Go): affected all versions; fixed in 1.8.14
- github.com/ethereum/go-ethereum (Go): affected all versions; fixed in 1.8.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-16733/ (Markdown: https://insights.sbomify.com/CVE-2018-16733/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-16733
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-16733
- OSV: https://osv.dev/vulnerability/CVE-2018-16733

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-16733/
Summaries are generated and may contain mistakes; the official description above is the record.
