CVE-2018-16738 Auth bypass in n/a

Low 3.7 Published Updated

Attackers can bypass authentication in tinc VPN software due to a broken protocol, allowing unauthorized access to the network.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2018-16738?

CVE-2018-16738 is a low-severity authentication bypass vulnerability in Debian Debian Linux, published on 10 Oct 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

tinc 1.0.30 through 1.0.34 has a broken authentication protocol, although there is a partial mitigation. This is fixed in 1.1.

Weakness: CWE-287

Which versions are affected by CVE-2018-16738?

It affects 3 products.

Products include Debian Debian Linux, Starwindsoftware Starwind Virtual San, Tinc-Vpn Tinc.

How do I fix CVE-2018-16738?

Upgrade to a fixed version.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2018-16738 being exploited?

There is no known exploitation of CVE-2018-16738 in the wild and no public exploit code.

All Debian Debian Linux vulnerabilities

Sources

Also known as ALPINE-CVE-2018-16738, DEBIAN-CVE-2018-16738, GHSA-c478-67p7-rg2p, UBUNTU-CVE-2018-16738.

Is CVE-2018-16738 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free